NetBackup™ Web UI クラウドオブジェクトストア管理者ガイド
- 概要
- クラウドオブジェクトストア資産の管理
- クラウドオブジェクトストア資産の保護
- クラウドオブジェクトストア資産のリカバリ
- トラブルシューティング
- 元のバケットリカバリオプションの Web UI を使用したクラウドオブジェクトストアのリカバリが開始されたが、ジョブがエラー 3601 で失敗する
- リカバリジョブが開始しない
- リストアが失敗しました: 「エラー bpbrm (PID=3899) クライアントのリストア 終了状態 40: ネットワーク接続が切断されました (Error bpbrm (PID=3899) client restore EXIT STATUS 40: network connection broken)」
- 既存の場所に上書きした後にアクセス層プロパティがリストアされない
- 複数のタグがある OR クエリーに対する Azure でのアクセラレータ最適化の低下
- バックアップが失敗し、ドット (.) を含む Amazon S3 バケット名で証明書エラーが表示される
- タグキー名または値のいずれかのタグクエリーにスペースが指定されていると、Azure バックアップジョブが失敗します。
- クラウドオブジェクトストアアカウントでエラーが発生した
- ポリシーの選択でバケットリストを選択するとバケットリストが空になる
- 既存の領域を選択すると Cloudian で 2 番目のアカウントの作成が失敗する
- 2825 未完了のリストア操作によりリストアに失敗した
- [クラウドオブジェクト (Cloud objects)]タブでバケットを追加すると、クラウドプロバイダのバケットの一覧表示に失敗する
- クラウドストアアカウントがターゲットドメインに追加されていない場合、ターゲットドメインで AIR インポートイメージのリストアが失敗する
クラウドオブジェクトストアアカウントでエラーが発生した
説明
Web UI で、クラウドオブジェクトストアアカウントの状態が「クラウドオブジェクトストアアカウントでエラーが発生しました。ユーザーマニュアルを参照してアカウントを再作成してください。(The Cloud object store account has encountered an error, see user documentation, and re-create the account.)」のように表示されます。
この状態では、クラウドオブジェクトストアアカウントを編集できません。クラウドオブジェクトストアアカウントに対応するすべてのジョブが失敗し続けます。
原因
クラウドオブジェクトストアアカウントは、次の場合にエラー状態になります。
csconfig CLI を使用して、クラウドオブジェクトストアアカウントに対応するエイリアスが誤って削除された。
csconfig CLI を使用して、クラウドオブジェクトストアアカウントに対応するエイリアスが誤って更新された。
メモ:
クラウドオブジェクトストアアカウントに対応するエイリアスの更新には、csconfig CLI を使用しないことをお勧めします。同じように更新する正しい方法は、編集ワークフローまたは create-or-update API を使用することです。クラウドオブジェクトストアアカウントと同じ名前のエイリアスが、クラウドオブジェクトストアアカウントに対応するエイリアスです。
回避方法
NetBackup ドメイン名は、クラウドオブジェクトストアアカウント、クラウドストレージサーバー、MSDP-C LSU 間で一意である必要があります。これらは単一の名前空間を共有します。そのため、想定される使用状況のシナリオは次のとおりです。
Case 1: クラウドオブジェクトストアアカウントと同じ名前の有効なクラウドストレージサーバーまたは MSDP-C LSU が環境内に存在しない場合。
環境に応じてクラウドオブジェクトストアアカウントの詳細を収集し、取得した詳細をクロスチェックします。
必要に応じて、クラウドオブジェクトストアアカウントに対応するエイリアスが存在する場合は、csconfig CLI を使用してエイリアスの詳細を書き留めます。
次のコマンドを使用して、このタイプのすべてのインスタンスを一覧表示し、クラウドオブジェクトストアアカウントとそのインスタンスを特定します。
<install-path>/csconfig cldinstance -i -pt <provider_type>
次のコマンドを使用して、インスタンスとクラウドオブジェクトストアアカウントの詳細を取得します。
<install-path>/csconfig cldinstance -i -in <instance name>
収集した情報で詳細を検証します。
次のコマンドを使用してエイリアスを削除します。
<install-path>/cscpnfig cldinstance -at <api_type> -rs -in <instance_name> -sts <cloud_object_store_account_name>
エラー状態のクラウドオブジェクトストアアカウントを削除します。
書き留めた詳細を使用して、クラウドオブジェクトストアアカウントを作成します。
Case 2: クラウドオブジェクトストアアカウントと同じ名前で使用中の有効なクラウドストレージサーバーまたは MSDP-C LSU が環境内に存在する場合。
同じ名前は再利用できません。
環境に応じてクラウドオブジェクトストアアカウントの詳細を収集する必要があります。
クラウドオブジェクトストアアカウントの新しい名前を決めます。
エラー状態のクラウドオブジェクトストアアカウントを削除します。ポリシーからアカウントを削除します。
新しい名前と収集した詳細を使用して、クラウドオブジェクトストアアカウントを作成します。古いアカウントが使用していたのと同じポリシーに、このアカウントを割り当てます。
これにより、次回のバックアップ以降、バケットに使用されるクライアント名が変更されます。
NetBackup は古いアカウント名を使用して、古いバックアップを識別します。