Veritas NetBackup™ Appliance Upgrade Guide

Last Published:
Product(s): Appliances (3.1.1 (5340), 3.1.1 (5330), 3.1.1 (5240), 3.1.1 (5230))

About upgrades to NetBackup appliance software version 3.1.1 and the Red Hat Enterprise Linux operating system

Starting with NetBackup appliance software version 2.7.1, Red Hat Enterprise Linux (RHEL) replaces the SUSE Linux Enterprise Server (SLES) operating system. You can upgrade any existing 5230, 5240, 5330, or 5340 appliances that currently use earlier software versions to version 3.1.1. In some situations, you may need to upgrade twice to get to version 3.1.1.

Note:

The NetBackup 5200 Appliance contains components that are not supported by RHEL version 6.6 or later. This limitation also prevents support for upgrades to software versions 2.7.1 and later.

Starting with version 3.1, you can upgrade appliances by using the Appliance Management Console. Appliances that use software versions 2.7.3 and 3.0 are also supported for upgrades through the console, if the appropriate EEB is installed before the upgrade. For more information, see the Veritas Appliance Management Guide.

Note:

Appliance upgrades to software version 3.1 and later are not supported from the NetBackup Appliance Web Console. To upgrade to version 3.1 or later, use the IPMI console to log in to the NetBackup Appliance Shell Menu or use the Appliance Management Console.

To upgrade the nodes in a high availability (HA) setup, you must use the NetBackup Appliance Shell Menu. The Appliance Management Console does not support upgrades for HA nodes.

Before you begin any upgrades, review the following topics:

See Supported upgrade paths.

See Preflight check before the upgrade.

See About upgrades for NetBackup Appliance HA setups.

See Third-party plug-ins for RHEL.

See Appliance behavior during upgrades.

See Changes during upgrades .

See About corresponding NetBackup software versions .

See About the Appliance Install Manager.