Problem
NetBackup 10.5 / 10.5.0.1 can be administered using the NetBackup Java GUI. However, when installing the NetBackup Java GUI 10.5 / 10.5.0.1 the back-level feature can not used to administer earlier NetBackup versions, even though the options may appear.
When installing the NetBackup Java GUI 10.5 or 10.5.0.1, the earlier back-level versions of the Java GUI will not work and these will hang when trying to login.
The NetBackup 10.5 / 10.5.0.1 Java GUI will login and operate as normal administering the 10.5.x platforms only.
Error Message
Primary server : bpjava-msvc log
04:36:48.166 [2203735] <2> delete_expired_ipc_with_session_token: Starting the deletion of session tokens.!
04:36:48.166 [2203735] <2> nbpas_get_system_signum: nbpas_sig=0 real_sig=0
04:36:48.166 [2203735] <16> isPidValid: PID is INVALID
04:36:48.166 [2203735] <2> delete_expired_ipc_with_session_token: Token file </usr/openv/var/session/bpjava_comm_ipc-2202868> successfully deleted.!
04:36:48.166 [2203735] <2> nbpas_get_system_signum: nbpas_sig=0 real_sig=0
04:36:48.166 [2203735] <16> isPidValid: PID is INVALID
04:36:48.166 [2203735] <2> delete_expired_ipc_with_session_token: Token file </usr/openv/var/session/c79ce491af02a5a148bd7431b3307c85e310e9846a7df88ace450042901093ed-2202868> successfully deleted.!
04:36:48.166 [2203735] <2> nbpas_get_system_signum: nbpas_sig=0 real_sig=0
04:36:48.166 [2203735] <2> nbpas_get_system_signum: nbpas_sig=0 real_sig=0
04:36:48.166 [2203735] <16> isPidValid: PID is INVALID
04:36:48.166 [2203735] <2> delete_expired_ipc_with_session_token: Token file </usr/openv/var/session/c79ce491af02a5a148bd7431b3307c85e310e9846a7df88ace450042901093ed-2202868_extra> successfully deleted.!
Java GUI example, where the login hangs and no errors occur.
Cause
Due to version updates of some of the Java and Spring binaries being used in NetBackup 10.5 / 10.5.0.1, the back-level versions provided for compatibility are not working.
Solution
For NetBackup primary servers which are pre-NetBackup 10.5, the additional installation of the specific NetBackup back level version of the Java GUI installation may be required. For example, if there are two versions of a NetBackup primary server that need administration, then both versions of the NetBackup Java GUI will need to be installed if one of the versions is NetBackup 10.5 or 10.5.0.1.
- For most previous versions of NetBackup Java GUI installations, the back-level feature is functional.
- As an alternate solution, the NetBackup Web UI is suggested, as this will be the replacement for the NetBackup Java GUI moving forward.
- A possible workaround exists. Contact NetBackup technical support for more information about this possible workaround.
This issue is currently under consideration for resolution in the next major product revision. There are no plans to address this issue via a patch or hotfix in the current or previous software versions at this time. Please note that we reserve the right to remove any fix from the targeted release if it fails quality assurance tests or introduces new risks to overall code stability. Our plans are subject to change, and any actions you take based on this information, or your reliance on it, are at your own risk.