Deletion of a Collection Task fails.

Article: 100074217
Last Published: 2025-04-18
Ratings: 0 0
Product(s): eDiscovery Platform

Problem

Attempted deletion of a collection task fails. 

Error Message

The following pop up will appear: 

[#422228] Could not delete task 

 

Cause

This issue can occur when the following property is set in the environment: esa.icp.task.deleteOnDiskTaskData and if the location of the collection s not accessible for some reason. 

The following are reasons why collection location may be unreachable are as follows:

  • Permissions for the folder of the collection location for the task may not be sufficient.
  • The folder for the collection location for the task could be corrupted. 
  • The folder for the collection location for the task may have been removed or deleted.  

 

To determine if the esa.icp.task.deleteOnDiskTaskData property is set perform the following steps:

  • From the user Interface select 'System' => 'Support Features'
  • From the 'Choose a support feature' drop down select 'Property Browser'.
  • Under 'Pattern to match enter the following: esa.icp.task.deleteOnDiskTaskData
  • Then select 'Submit' button. 
  • If it returns "esa.icp.task.deleteOnDiskTaskData = true" then this property is enabled.

To determine the collection location of the task, perform the following: 

  • From the User Interface select 'All Collections'
  • Under Collections select the associated collection.
  • Then under the 'Status' column select the hyperlink. 

 

  • Then the 'Collection Task Status' window will appear providing the collection folder location for the task. 
  •  

Solution

To work around this issue use the following tech note to remove the property

How To Auto Delete The Collection Task Data From The Preservation Store (Destination)

Then delete the task. 

When completed, you can use the same tech note to add the property back if necessary.  

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