Important Update: Cohesity Products Knowledge Base Articles
All Cohesity Knowledge Base Articles are now managed via the Cohesity Support Portal: https://support.cohesity.com/s/searchunify. The Knowledge Base articles available here will not reflect the latest information or may no longer be accessible.
問題
管理対象 Backup Exec サーバー (MBES) をバージョン 22.0 へアップグレードする際にデータベースの移行段階で失敗する場合があります。
エラーメッセージ
BKUPINST22.HTM ログ (インストールログ) に以下のエラーが表示されます。
DBUTIL;DataTypeCompatibility=80 hr=0x0
01-28-2022,03:17:42 : SQL Server Network Interfaces: Error Locating Server/Instance Specified [xFFFFFFFF].
01-28-2022,03:17:42 : OLE DB provider "SQLNCLI11" for linked server "ADAMM_DB" returned message "A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online.".
01-28-2022,03:17:42 : OLE DB provider "SQLNCLI11" for linked server "ADAMM_DB" returned message "Login timeout expired".
01-28-2022,03:17:42 : dbutil RunSQLScript: execute sql cmd failed. sql statement: CREATE FUNCTION [dbo].[TELEMETRY.ADAMM.StorageDevices2] ( ) RETURNS XML AS BEGIN declare @KBytes bigint set @KBytes = 1024 declare @ret XML; declare @returnTable TABLE ( StorageDevice nvarchar(255), SerialNumber nvarchar(255), DeviceType int, DeviceState int, DriveType int, DeviceName nvarchar(255), DeviceGuid uniqueidentifier, ParentGuid uniqueidentifier, DiskSizeKBytes bigint, FreeSpaceKByte
01-28-2022,03:17:42 : dbutil RunSQLScript:Stop execution sql script
01-28-2022,03:17:42 : dbutil RunSQLScript: failed: 0x80040e14
01-28-2022,03:17:42 : OS ERROR: 0x80040e14 (-2147217900)
01-28-2022,03:17:42 : upgrade20x ends rc=1
01-28-2022,03:17:42 : Job Migration Failed
原因
1. 集中管理サーバー (CAS) が Backup Exec 22.0 に正常にアップグレードされ、CAS サーバーのデータベース (BEDB) が 64ビット版 SQL Express 2017 にアップグレードされ、インスタンス名が BKUPXEC64 に変更されます。
2. CAS が正常にアップグレードされた時点で CAS から 問題の MBESを検出できなかったため、インストーラが MBES 設定を更新できません。
結果、MBES のレジストリ設定の一部は、CAS 上にすでに存在しない旧名称の BKUPEXEC インスタンスを指しているため、Backup Exec Device and Media Service (PVLSVR.EXE) が開始できません。
解決策
問題の MBES で、次の手順を実行します。
1. すべての Backup Exec サービスを停止します。
2. 次のレジストリを更新します。
HKEY_LOCAL_MACHINE\SOFTWARE\Veritas\Backup Exec For Windows\Adamm
(文字列型) Database Instance Name
(文字列型) Database Server Name
Database Instance Name を BKUPEXEC64 に更新します。
Database Server Name が CAS のホスト名であることを確認します。
3. すべての BE サービスを開始します。
上記の手順を実行し、MBES 上の Device and Media Service が正常に開始できることを確認後に、Backup Exec 22 にアップグレードします。