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Upgrade of a Managed Backup Exec server (MBES) to Backup Exec version 22.0 may fail during the database migration stage.
Problem
Upgrade of a Managed Backup Exec server (MBES) to Backup Exec version 22.0 may fail during the database migration stage.
Error Message
BKUPINST22.HTM log shows below error -
DBUTIL;DataTypeCompatibility=80 hr=0x0
01-28-2022,03:17:42 : SQL Server Network Interfaces: Error Locating Server/Instance Specified [xFFFFFFFF].
01-28-2022,03:17:42 : OLE DB provider "SQLNCLI11" for linked server "ADAMM_DB" returned message "A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online.".
01-28-2022,03:17:42 : OLE DB provider "SQLNCLI11" for linked server "ADAMM_DB" returned message "Login timeout expired".
01-28-2022,03:17:42 : dbutil RunSQLScript: execute sql cmd failed. sql statement: CREATE FUNCTION [dbo].[TELEMETRY.ADAMM.StorageDevices2] ( ) RETURNS XML AS BEGIN declare @KBytes bigint set @KBytes = 1024 declare @ret XML; declare @returnTable TABLE ( StorageDevice nvarchar(255), SerialNumber nvarchar(255), DeviceType int, DeviceState int, DriveType int, DeviceName nvarchar(255), DeviceGuid uniqueidentifier, ParentGuid uniqueidentifier, DiskSizeKBytes bigint, FreeSpaceKByte
01-28-2022,03:17:42 : dbutil RunSQLScript:Stop execution sql script
01-28-2022,03:17:42 : dbutil RunSQLScript: failed: 0x80040e14
01-28-2022,03:17:42 : OS ERROR: 0x80040e14 (-2147217900)
01-28-2022,03:17:42 : upgrade20x ends rc=1
01-28-2022,03:17:42 : Job Migration Failed
Cause
1. The Central Administration Server (CAS) was upgraded to BE 22.0 successfully and the CAS Backup Exec Database (BEDB) hosted in a local SQL Express 2017 64-bit instance named BKUPXEC64.
2. The MBES (the one which showed failure) probably was not reachable from the CAS at the time when CAS upgraded successfully and hence the installer could not update the MBES settings.
In this case, the MBES will have some of its registry settings point to a non-existent SQL Express BKUPEXEC instance ( Earlier BE default Instance ) on the CAS. The Backup Exec Device and Media service (PVLSVR.EXE) will not be able to start.
Solution
On MBES which shows upgrade failure perform the following -
1. Stop all BE services
2. Update the following registry -
HKEY_LOCAL_MACHINE\SOFTWARE\Veritas\Backup Exec For Windows\Adamm
(String Value) Database Instance Name
(String Value) Database Server Name
Database Instance Name should be updated to BKUPEXEC64
Database Server Name should be updated to CAS server hostname
3. Start all BE services.
You can upgrade to BE 22 after the above steps are performed and Device and Media service on MBES is able to start successfully.