During the 'Applying patch, please wait...' phase, the upgrade fails with ' Error in NLP: Code -D1104 '

Article: 100052034
Last Published: 2022-04-11
Ratings: 3 0
Product(s): eDiscovery Platform

Problem

Applying a Cumlutive Hotfix upgrade to the eDiscovery Product (eDP), if an encrypted password fails verification, the upgrade will fail during the 'Applying Patch' phase.

Error Message

Upon examining the 'b_cmd_ApplyPatch' log, the last entry will contain the error:

error: Error installing patch: [#80007] Unexpected exception encountered: Error in NLP: Code .-D1104

Cause

One or more of the encrypted passwords is different between the default.properties and esa.properties files.
D:\CW\Vxx\config\configs\default.properties
D:\CW\Vxx\scratch\esa\esa.properties

The most common password difference is the esa.classifier_service.service.password.

List of passwords to verify:
esa.uploader.ftp.password
esa.crawler.ev.service.password
esa.uploader.http.password
esa.nexidia.clientkey
esa.ldap.connectionPassword
esa.lh.ldap.connectionPassword
esa.postgresql.dbmsSystemPassword
esa.mysql.dbmsSystemPassword
esa.classifier_service.service.password
esa.crawler.service.password
esa.audio.nexidia.password
esa.retriever.riss.service.password
esa.cert.keystore.password
esa.retriever.pst.service.password
esa.crawler.pst.service.password
esa.common.db.system.password
esa.retriever.exch.service.password
esa.retriever.nsf.service.password
esa.audio.service.admin.pwd
esa.crawler.nsf.service.password
esa.crawler.riss.service.password
esa.cert.cwkeystore.password
esa.common.webapp.appserver.servicePassword
esa.common.winauth.password
esa.crawler.exch.service.password
esa.system.support.privilegedPassword
esa.retriever.ev.service.password
esa.audio.service.index.pwd
esa.common.db.password

 

Solution

Once the incorrect password variable is determined,

1. Make a backup copy of the default.properties and esa.properties files

2. Modify the default.properties to match the esa.properties file.

3. Restart eDP services

4. Execute the upgrade process again.

Option 2: Distributed Architecture Only
Worker Node Only

1. Make sure the following folder on the failing 'worker node' is empty.
D:\CWShared\ClusterMasterParameters

2. Run Option 7 of the Clearwell Utilites (incremental Rebuild)
 

 

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