Windows Master server failed in upgrading to NetBackup 8.3, Operations for independently-upgradeable components [Veritas NetBackup JRE] failed with [1603]. MsiDoAction() returned with error code [1603].
Problem
Windows Master server failed to upgrade from NetBackup 8.1.2 to 8.3, the error happened in JRE package installation.
Error Message
Action ended 16:11:39: Immediate_StopBaseProduct. Return value 3
Operations for independently-upgradeable components [Veritas NetBackup JRE] failed with [1603]. MsiDoAction() returned with error code [1603].
The upgrade log file may have such information:
...08-11-2020,16:10:38 : Executing command: "V:\Veritas\\NetBackup\bin\bpdown.exe" -f -v.
08-11-2020,16:11:38 : Reading pipe broken.
08-11-2020,16:11:38 : The process terminated.
08-11-2020,16:11:38 : Command exited with status 5.
...08-11-2020,16:11:39 : Finished with StopBaseProduct custom action.
08-11-2020,16:11:39 : CustomAction Immediate_StopBaseProduct returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
+ 08-11-2020,16:11:39 : Action ended 16:11:39: Immediate_StopBaseProduct. Return value 3.
08-11-2020,16:11:39 : Action 16:11:39: Immediate_CopyLogFile_OnError. Copying log file to permanent location
08-11-2020,16:11:39 : Action start 16:11:39: Immediate_CopyLogFile_OnError.
+ 08-11-2020,16:11:39 : Action ended 16:11:39: INSTALL. Return value 3.
...+ 08-11-2020,16:11:41 : Action ended 16:11:41: INSTALL. Return value 3.
08-11-2020,16:11:41 : MsiDoAction() returned with error code [1603].
08-11-2020,16:11:41 : Product operation returned status [1603].
+ 08-11-2020,16:11:41 : Operations for independently-upgradeable components [Veritas NetBackup JRE] failed with [1603]. MsiDoAction() returned with error code [1603].
08-11-2020,16:11:41 : -------------------------------------------------------------------------------
...
Cause
This Veritas NetBackup JRE package installation failure is caused by the status code 5 that "bpdown -f -v" returns. At some time, the "bpdown -f -v" gets SC 5 even though all NetBackup services have been down.
Solution
An Emergency Engineering Binary (EEB) containing a fix for this issue is available by contacting Veritas technical support, referencing this document ID and the version specific EEB:
- Etrack ID 4011563 for NetBackup 8.3
- Etrack ID 4022764 for NetBackup 8.3.0.1
Then, apply the version specific EEB as per requirement.