NetBackup upgrade failure with KeyStore.lock file errors

Article: 100051607
Last Published: 2025-01-10
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

Upgrading to NetBackup 9.x and above fails when the KeyStore.lock file does not have the required permissions.

Error Message

The following error can be seen in the NetBackup install logs from the following location:

%ALLUSERSPROFILE%\Veritas\NetBackup\InstallLogs\

ERROR: Could not delete \\?\F:\Program Files\Veritas\NetBackup\var\global\vxss\eab\data\systemprofile\certstore\keystore\KeyStore.lock.
System Error: 32, The process cannot access the file because it is being used by another process.
We couldn't identify the offending processes that are holding on to the file.

 

ERROR: Could not delete \\?\F:\Program Files\Veritas\NetBackup\var\global\vxss\eab\data\systemprofile\certstore\keystore.
System Error: 145, The directory is not empty.

 

Cause

Required permissions to access the KeyStore.lock are missing. 

Solution

1) Stop All Netbackup services.

2) Remove the KeyStore.lock file from the below location:

<Install Path>\Veritas\NetBackup\var\global\vxss\tomcatcreds\nbwebsvc\certstore\keystore\KeyStore.lock   (NOTE:  The exact path and file in question may differ from the one shown here.  Be sure to only delete the .lock file that is generating the error)

3) Start Netbackup services to recreate the KeyStore.lock file

4) Add the NetBackup Web Services Account with "Full Control" permissions to the KeyStore.lock file (See example below).

5) Perform the upgrade again.

 

 

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