Important Update: Cohesity Products Knowledge Base Articles
All Cohesity Knowledge Base Articles are now managed via the Cohesity Support Portal: https://support.cohesity.com/s/searchunify. The Knowledge Base articles available here will not reflect the latest information or may no longer be accessible.
During archiving, Attachments can sometimes be stored in the wrong partition when using an HCP device
Problem
Under certain conditions, during the archiving process, when items are being archived by Enterprise Vault (EV) to a Hitachi Content Platform (HCP) device, the attachment(s) (the DVSSP file) can be stored in the wrong partition on the HCP device.
This situation can occur if all the following is true:
- At least 2 Vaultstores have been configured with an active partition
- Sharing has been configured across the Vault Store Group for the Vaultstores
- The following field in the EnterpriseVaultDirectory database has been manually updated and set to 1 (from the default value of 0): [VaultStoreGroup].[ArchiveSISPartVerificationLevel]
When files have been stored on the wrong partition, retrieval of the archived item will fail. Usually, the first indication that this issue has occurred would be an error being reported in the EV event log during the Indexing of the item when the associated StorageCrawler process fails to retrieve the item from the partition.
The following version(s) of EV is affected:
1. Enterprise Vault 12.x.x
Error Message
The indexing and retrieval process will fail for the affected items as Enterprise Vault (EV).
Type : Error
Date : 24/04/2019
Time : 20:06:45
Event : 28998
Source : Enterprise Vault
Category : Storage Crawler
User : N/A
Computer : EV Server 1
Description:
Retrieval of a saveset failed.
Reason: The system cannot find the file specified. (0x80070002)
Saveset Id: 201912270000000~201610130444140000~Z~90D69679A1B3F81AB6A183BB759172A1
Vault Id: 15B1127117A6454419D2417C28B9C87A71110000EV1
Index Sequence Number: 15469
Internal Reference: Fetching Saveset for indexing
Cause
Setting the ArchiveSISPartVerificationLevel field to 1 means that EV will validate the existance of a shared item before re-using it. If the shared item verified is on a different partition, that partition is wrongly used to store the new item.
Solution
This issue is fixed in Enterprise Vault 12.4.2, which is available in the Download Center, please go to support.veritas.com to obtain this update
For more information about Messages (DVS files) being stored in the wrong partition, which has been resolved in version 12.4.0, please refer to article 100045808