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NetBackup IT Analytics - WMI Debugging, Data collector can't connect to Windows hosts, getting "Access is denied" error

Article: 100045392
Last Published: 2015-12-30
Ratings: 0 2
Product(s): NetBackup IT Analytics, NetBackup

Problem

NetBackup IT Analytics is having problems with host data collection and data collectors can't connect to Windows hosts, getting Access is denied error. This article focuses on WMI debugging using Windows tools, which are completely separate from NetBackup IT Analytics software. This WMI connection needs to work first in order for NetBackup IT Analytics data collector to make connections to Windows target hosts and capture data.

 

Error Message

Access is denied
 

Cause

WMI Debugging data collectors can't connect to Windows hosts, getting Access is denied error.
 

Solution

Debugging Steps:

  • Test whether WMI commands can be run from the Data Collector Server against the remote Host using Windows Command - wmic or WMI GUI wbemtest.exe
     
  • Once the above is working, test it using Aptare Command - checkwmiproxy.bat for more details about this tool and Host Resources Troubleshooting guide, please visit the online documentation: 
    Host resources: Check the status of the WMI proxy serverhttps://www.veritas.com/support/en_US/doc/140726114-164220991-0/pgfId-1012960-164220991


1) Testing WMI Connection from wmic:

C:\Documents and Settings\Administrator> wmic /node:exchange2007 path win32_operatingsystem
Node - exchange2007
ERROR:
Code = 0x800706ba
Description = The RPC server is unavailable.
Facility = Win32


The above problem happens because of an incorrect server name.

C:\Documents and Settings\Administrator> wmic /node:exchange2007.exch2007.lab path win32_operatingsystem
Node - exchange2007.exch2007.lab
ERROR:
Code = 0x80070005
Description = Access is denied.
Facility = Win32


The above problem happens because of Missing Credentials, Incorrect Credentials, Account is locked out or Firewall Issues. You may also want to verify it by logging in using Windows Remote Desktop.

Below is the working version of the command. This results in the output of commands invoked.

C:\Documents and Settings\Administrator>wmic /node:exchange2007.exch2007.lab /user:"EXCH2007\Administrator" path win32_operatingsystem

Enter the password :******

BootDevice BuildNumber BuildType Caption CodeSet CountryCode CreationClassName C
SCreationClassName CSDVersion CSName CurrentTimeZone DataExecutionPrevention_32BitApplications
DataExecutionPrevention_Available DataExec
utionPrevention_Drivers DataExecutionPrevention_SupportPolicy Debug Description Distributed EncryptionLevel
ForegroundApplicationBoost FreePhys
icalMemory FreeSpaceInPagingFiles FreeVirtualMemory InstallDate LargeSystemCache LastBootUpTime LocalDateTime
Locale Manufacturer MaxNumberOfProcesses MaxProcessMemorySize MUILanguages Name
NumberOfLicensedUsers NumberOfProcesses NumberOfUsers OperatingSystemSKU Organization OSArchitecture
OSLanguage OS
ProductSuite OSType OtherTypeDescription PAEEnabled PlusProductID PlusVersionNumber Primary ProductType RegisteredUser
SerialNumber
ServicePackMajorVersion ServicePackMinorVersion SizeStoredInPagingFiles Status SuiteMask SystemDevice SystemDirectory
SystemD
rive TotalSwapSpaceSize TotalVirtualMemorySize TotalVisibleMemorySize Version WindowsDirectory
\Device\HarddiskVolume1 7600 Multiprocessor Free Microsoft Windows Server 2008 R2 Enterprise 1252 1
Win32_OperatingSystem W
in32_ComputerSystem EXCHANGE2007 -420 TRUE TRUE TRUE
Unknown macro: {"en-US"}
Microsoft Windows Server 2008 R2 Enterprise |C:\Windows|\
Device\Harddisk0\Partition2 0 73 2 10 



2) Testing WMI Connection from Standard Windows Server WMI GUI wbemtest.exe

Run wbemtest.exe on the WMI Proxy Server.

In the Connect Window, enter \\ServerName\root\cimv2 in the namespace field.

Enter Credentials: User, Password, Authority (Means NTLM Domain)

Connect and then perform Enum Classes or select queries. For example: select * from win32_operatingsystem
 

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