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General Error - The RPC server is unavailable

Article: 100060228
Last Published: 2023-12-07
Ratings: 0 1
Product(s): NetBackup, NetBackup IT Analytics

Problem

While using Veritas NetBackup software, an error may be received indicating that the RPC server is unavailable.

Error Message

The NetBackup software may show the following error:

The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)

The Windows Event Administrative logs may show the following error:

The RPC server is unavailable. 0x800706ba (WIN32: 1722 RPC_S_SERVER_UNAVAILABLE)

Cause

This issue appears to be outside of the NetBackup software and is happening on the network layer.

Examples of potential causes:

  1. Firewall blocking remote computer.
  2. Incorrect hostname or IP address.
  3. Remote computer shut down.
  4. TCP/IP NetBIOS Helper service not running.
  5. Remote Procedure Call (RPC) service not running on remote computer.
  6. Windows Management Instrumentation service not running on remote computer.
  7. Incorrect DNS settings.
  8. Incorrect time and time zone settings.
  9. Remote Registry service not running.
  10. Network blocking Microsoft Remote Procedure Call (MSRPC) services, preventing execution of RemoteScriptReturnOutput() function.
  11. Firewall or other security measures blocking necessary ports or protocols used by MSRPC.

Note: This is not an exhausted list of causes.

Solution

Since this is not a NetBackup issue, we recommend consulting with local system and/or network administrators to resolve this issue.

Examples of items to check:

  1. Check firewall settings and if it's blocking the remote computer:
    • Open Group Policy Object Editor (gpedit.msc).
    • Edit Group Policy object (GPO) for Windows Firewall settings.
    • Enable exceptions: Allow Remote Administration Exception and Allow File and Printer Sharing Exception.
  2. Check the hostname or IP address and if it's incorrect:
    • Correct hostname or IP address.
  3. Check if the remote computer is turned on.
  4. Check the TCP/IP NetBIOS Helper service status and if it's not running:
    • Start service and set to auto-start after restart.
  5. Check the Remote Procedure Call (RPC) service status on the remote computer and if it's not running:
    • Start service and set to auto-start after restart.
  6. Check the Windows Management Instrumentation service status on the remote computer and if it's not running:
    • Start service and set to auto-start after restart.
  7. Check DNS settings.
  8. Check time and time zone settings.
  9. Check Remote Registry service status.
  10. Check if the network is blocking the MSRPC services.
  11. Take steps to unblock the MSRPC services by configuring the firewall or other security measures to allow traffic on the necessary ports or protocols used by MSRPC.

Note: This is not an exhausted list of potential solutions.

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