Important Update: Cohesity Products Knowledge Base Articles
All Cohesity Knowledge Base Articles are now managed via the Cohesity Support Portal: https://support.cohesity.com/s/searchunify. The Knowledge Base articles available here will not reflect the latest information or may no longer be accessible.
NetBackup snapshot with CloudPoint integration may fail with "failed to get media server list for the application server" after deleting CloudPoint host from NetBackup
Problem
After deleting the CloudPoint credentials from Snapshot Server Management, next snapshot job may fail with "Status 922 - failed to get media server list for the application server".
Error Message
Status 922 - failed to get media server list for the application server
Job Details:
NBU status: 922, EMM status: failed to get media server list for the application server
Cause
This occurs because NetBackup is still referencing the old CloudPoint server, and a new discovery job has not occurred since removing the CloudPoint credentials.
Solution
Force a new discovery job to run by stopping and restarting the NetBackup Discovery Framework service.
Windows:
# net stop "NetBackup Discovery Framework"
The NetBackup Discovery Framework service is stopping.
The NetBackup Discovery Framework service was stopped successfully.
# net start "NetBackup Discovery Framework"
The NetBackup Discovery Framework service is starting.
The NetBackup Discovery Framework service was started successfully.
Linux:
Stop the daemon:
# /usr/openv/netbackup/bin/nbdisco -terminate
To start run:
# /usr/openv/netbackup/bin/nbdisco
Also verify that the new or existing CloudPoint server has the plugin configured to snapshot your assets.
Windows:
installpath\Veritas\Volmgr\bin\tpconfig -list_plugins -cloudpoint_server <cloudpoint_server>
Linux:
# /usr/openv/volmgr/bin/tpconfig -list_plugins -cloudpoint_server <cloudpoint_server>