VMware backups failing with status 23 "Error opening the snapshot disks using given transport mode".

VMware backups failing with status 23 "Error opening the snapshot disks using given transport mode".

Article: 100009930
Last Published: 2014-01-14
Ratings: 2 3
Product(s): NetBackup

Problem

VMware backups failing with status 23 "Error opening the snapshot disks using given transport mode".

Error Message

By examining the logs, bpbkar shows the following:

9:31:05.538 AM: [8352.6000] <2> tar_base::V_vTarMsgW: INF - VxMS Error message 1 = Error opening snapshot disk(s) using given transport mode(s)
message 2 = Error opening snapshot disk(s) using given transport mode(s)
9:31:05.541 AM: [8352.6000] <4> tar_base::V_vTarMsgW: INF - tar message received from vxms_error_handler
..
9:31:05.701 AM: [8352.6000] <2> tar_base::V_vTarMsgW: ERR - Error opening the snapshot disks using given transport mode: Status 23.

VxMs log shows:

07/03/2013 09:31:04.0781 : g_vdInterfaceLogger:.\libvix.cpp:1683 <INFO> : diskLibPlugin: 2013-07-03T09:31:04.781-07:00 [06000 trivia 'Default'] Attempting to open LVID:50a30156-cb93d8f8-d1b7-842b2b553950/50a300d3-f249fee3-b62c-842b2b553950/1.
07/03/2013 09:31:04.0781 : g_vdInterfaceLogger:.\libvix.cpp:1683 <INFO> : diskLibPlugin: 2013-07-03T09:31:04.781-07:00 [06000 error 'Default'] No path to device LVID:50a30156-cb93d8f8-d1b7-842b2b553950/50a300d3-f249fee3-b62c-842b2b553950/1 found.
07/03/2013 09:31:04.0781 : g_vdInterfaceLogger:.\libvix.cpp:1683 <INFO> : diskLibPlugin: 2013-07-03T09:31:04.781-07:00 [06000 error 'Default'] Failed to open new LUN LVID:50a30156-cb93d8f8-d1b7-842b2b553950/50a300d3-f249fee3-b62c-842b2b553950/1.
 07/03/2013 09:31:05.0438 : g_vdInterfaceLogger:.\libvix.cpp:1683 <INFO> : diskLibPlugin: 2013-07-03T09:31:05.438-07:00 [06000 error 'BlockList'] Other error encountered: vim.fault.CannotAccessFile

Cause

The LUN hosting the datastore is not properly zoned to the VM backup host.

There is also a known VMware issue that could cause this error when trying to access a thin unallocated disk which is not a lun.

Solution

Two possible issues:
1. Zoning issue between the VMware Backup Host and the Datastores/LUNs.
2. Address the thin unallocated disk that is not a lun.  (https://kb.vmware.com/kb/2145341)

 

Related Articles:

How to check if a VMware datastore is presented on SAN to a Windows NetBackup host

How to check if a VMware datastore is presented on SAN to a Linux NetBackup host or a NetBackup Appliance

 

 

Was this content helpful?