Problem
Enterprise Vault (EV) advanced searches fail when using a date range. The same search without a date range works fine.
Error Message
The user is presented with the following error message:-
"Your search request failed. Wait and try again"
EV Environments Affected
EV 12.2.0, 12.2.1, 12.2.2, 12.2.3, 12.3, 12.3.1, 12.3.2
Snippets from the dtrace the 'w3wp' process will reveal the following error:
{SOAPSearchService} Exception: The time zone ID 'Australia/Adelaide' was not found on the local computer. Info:
Search failed. Diag: Type:System.TimeZoneNotFoundException ST: at System.TimeZoneInfo.FindSystemTimeZoneById(String id)| at Symantec.EnterpriseVault.Indexing.Search.BooleanTextDateValue.GetUtcOffset(DateTime dt)|.........
Cause
This is caused by the client having the client time zone set to Adelaide. This returns the time zone as Australia/Adelaide but there is no time zone in the list named Australia/Adelaide.
Solution
Work Around:
Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
On the EV server perform the following steps to create a time zone called Australia/Adelaide in the registry:-
1. Enter the registry and navigate to the following location:-
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Time Zones
2. Export the Cen. Australia Standard Time key to TimeZoneFix.REG file.
3. Edit TimeZoneFix.REG file and replace the two instances of Cen. Australia Standard Time with Australia/Adelaide.
4. Run TimeZoneFix.REG.
5. Check the registry location and confirm the registry hive Australia/Adelaide has been created.
6. Run the search that was previously failing, and it will now work fine.
Fixed:
This issue has been fixed in EV 12.4.1 and 12.5. However, as there are two other known issues relating to Date Range searches in these versions it is recommended to upgrade to either EV 12.5.3 or EV 14.1.
Enterprise Vault versions downloads available at Downloads.
Please review the following for other known Date Range search issues.
https://www.veritas.com/content/support/en_US/article.100046527
https://www.veritas.com/support/en_US/article.100049616