Problem
When a user attempts to manually archive a message or retrieve a shortcut within Outlook, the error below is shown:
Error Message
Could not process the selected items
Reason : A Server error has occurred.
Reviewing the client trace shows:
20/08/2012 14:54:09.798[1404]: HTTP request error: 58 (400)
20/08/2012 14:54:09.798[1404]: Connect failed, unmarking items: 0x80004005
20/08/2012 14:54:09.798[1404]: CHTTPRequest::UnmarkItems: 0x0
20/08/2012 14:54:12.529[1404]: ~CHTTPRequest::UnmarkItems: 0x0
20/08/2012 14:54:12.529[1404]: ::~CInternetReconnect
20/08/2012 14:54:12.529[1404]: ::CInternetReconnect - refCount : 1
20/08/2012 14:54:12.529[1404]: ~::~CInternetReconnect
20/08/2012 14:54:12.529[1404]: ~CHTTPRequest::ThreadMain: 0x80004005
20/08/2012 14:54:12.529[1404]: CThreadManager::Remove thread THID=1404
A Dtrace during the archive attempt shows:
10:56:33.187 [1396] (DirectoryService) <5508> EV~E Event ID: 8391 The EnterpriseVault.DirectoryService object reported an error.| |Unspecified error| |
12 10:56:33.187 [4428] (w3wp) <2092> EV:M HRXEX fn trace :|Source : .\AutoAgentsOnline.cpp (CAutoAgentsOnline::GetExchangeAgentDetailsEx) [lines {212,221,241}] built Aug 6 19:34:03 2010|Description: Call error 0x80004005
13 10:56:33.187 [4428] (w3wp) <2092> EV:M CAutoAgentsOnline::GetExchangeAgentDetailsEx - Com Exception [0x80004005]
14 10:56:33.187 [4428] (w3wp) <2092> EV:M CAutoAgentsOnline::RequestAction - Failed to Locate Corresponding Task - Exchange [EXCH2007]|Mailbox [/o=Example/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=vaultuser]|FolderPath []
15 10:56:33.187 [4428] (w3wp) <2092> EV:M CAutoAgentsOnline::RequestAction - Com Result [0xC0040B28]
V-437-8391
V-437-8390
Cause
There are 4 potential scenarios:
1. User mailbox has been moved to an Exchange server that is not configured as a target for EV
2. User mailbox is missing an entry in the database
3. Vault Service account is in the Domain Admins group. This could also cause the archive tasks to fail and other operations to not function.
4. Mismatch of LegacyExchangeDn being reported in Dtrace/SQL compared to ADSIEDIT for the mailbox.
Solution
Scenario 1:
1. Add the Exchange server as a target
2. Once the target has been added, create a new Archive Task and run Synchronization
Scenario 2:
1. Manually run the Provisioning Task and confirm the user account has been provisioned by reviewing the Provisioning Report
Scenario 3:
1. Remove the Vault Service Account from the Domain Admins AD group
Scenario 4:
1. Change the LegacyMbxDn value in SQL to match the LegacyExchangeDn value found in ADSIEDIT, or change the LegacyExchangeDn value in ADSIEDIT to match what is found for LegacyMbxDn value found in SQL for the mailbox so that they match.
Also take a look at Article 100023790 for a similar issue caused by special characters.