The Enterprise Vault Office Mail App Store and Restore operations fail when the user's LegacyExchangeDN attribute contains HTTP reserved characters

Article: 100023790
Last Published: 2020-02-13
Ratings: 0 0
Product(s): Enterprise Vault

Problem

When a user uses the Enterprise Vault Office Mail App to Store or Restore an item, the operation fails.

Error Message

The user sees the following error message:

A dtrace of the w3wp process contains the following error:

11923    11:49:37.193     [5344]    (w3wp)    <796>    EV:H    {CAutoAgentsOnline::GetExchangeAgentDetailsEx} HRXEX fn trace : Error [0x80004005], [.\AutoAgentsOnline.cpp, lines {178,187,208}, built Apr  2 11:54:49 2014].
11924    11:49:37.209     [5344]    (w3wp)    <796>    EV:M    CAutoAgentsOnline::GetExchangeAgentDetailsEx - Com Exception [0x80004005]
11925    11:49:37.209     [5344]    (w3wp)    <796>    EV:M    CAutoAgentsOnline::RequestActionForItems - Failed to Locate Corresponding Task - Exchange [EX2013-MBX]|Mailbox [/o=Lock Stock ]|FolderPath [ ]
11926    11:49:37.209     [5344]    (w3wp)    <796>    EV:M    CAutoAgentsOnline::RequestActionForItems - Com Result [0xC0040B28]

Cause

The user's LegacyExchangeDN attribute contains a character from the HTTP reserved character set. This causes the Office Mail App's store or restore request to be truncated prematurely, resulting in a bad request.

In this example, the Organization name ('/o') of the mailbox has an ampersand ('&') character in it.

 

The Provisioning Task synchronizes this to the ExchangeMailboxEntry table as LegacyMbxDn:

 

Note how in the dtrace, the Maibox value is truncated at the '&' character:

Mailbox [/o=Lock Stock ]|FolderPath [ ]

The correct value should be

Mailbox [/o=Lock Stock & Barrel/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=060f97917ecd4caaa9be8aef7db8a309-User]|FolderPath [ ]

But because the & is a reserved character, it is interpreted as the start of a new parameter rather than as part of the current string.

Solution

A workaround exists for prior versions of EV 11.0.1.  Please contact Technical Support if you are unable to upgrade to 11.0.1 CHF4.
 

For additional solutions to similar symptoms see also Article 100027608



This issue is resolved in the following release:

Enterprise Vault 11.0.1 CHF4 Release Details
https://www.veritas.com/support/en_US/article.000097959

References

Etrack : 3851727

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