Trying to start Backup Exec services fails with "The Backup Exec Device and Media Service could not start because the database recovery has failed. Refer to the database recovery log for details."

Article: 100022672
Last Published: 2017-12-05
Ratings: 1 0
Product(s): Backup Exec

Problem

Trying to start Backup Exec services fails with "The Backup Exec Device and Media Service could not start because the database recovery has failed. Refer to the database recovery log for details."

 

Error Message

Trying to start the Backup Exec Device and Media service fails with "The Backup Exec Device and Media Service could not start because the database recovery has failed.  Refer to the database recovery log for details.", and the remote Backup Exec Database (BEDB) is detached on the SQL server.  

Below entry is seen in the media servers Application Event log: 

Type: Error
Event: 58068
Source: Backup Exec
Category: None
User: N/A
Computer: SCBACKUP
Description:
The Backup Exec Device and Media Service could not start because the database recovery has failed.  Refer to the database recovery log for details.
 

Review of the Backup Exec Database Recovery log (default C:\Program Files\Symantec\Backup Exec\Logs\dbrecover.log) reports the following error:
 
     File Exist Check: \\<remote SQL server name>\E$\data\BEDB_dat.mdf
File Exist: FALSE
File Exist Check: \\<remote SQL server name>\E$\logs\BEDB_log.ldf
File Exist: FALSE
 
Create database BEDB
Execute command: create database BEDB on(name=BEDB_dat, filename='E:\data\BEDB_dat.mdf') log on (name=BEDB_log, filename='E:\logs\BEDB_log.ldf')
OpenFromInitializationString Connection String = Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=master;Data Source=SCSQL;Locale Identifier=1033;Application Name=BEWS DBUTIL hr=0x0
CREATE DATABASE failed. Some file names listed could not be created. Check related errors.
Directory lookup for the file "E:\logs\BEDB_log.ldf" failed with the operating system error 2(The system cannot find the file specified.).
Execute command failed: 0x80040e14
OS ERROR: 0x80040e14 (-2147217900)
Deinitialize... 
-----------------------------
Process completed
Status: DBU_ERROR_DATABASE_CREATE_FAILED 
-----------------------------

 

Cause

The Backup Exec Database files were located in different paths (E:\data and F:\logs drive) and with different file names (BEDB.MDF and BEDB_1.LDF).  

UMI Code: V-379-58068

Solution

To correct the issue, perform the following:
  1. Detach BEDB in the SQL Studio Management Tool on the SQL server
  2. Rename the Backup Exec database files to "BEDB_DAT.MDF" and "BEDB_LOG.LDF"  (default file names)
  3. Attach BEDB again
  4. Correct "HKLM\SOFTWARE\Symantec\Backup Exec for Windows Servers\BEDatabase\
    1. "\Server Database Log Path\"   to show the actual path to the Backup Exec Database log file 
    2. "\Server Database Path\"    to show the actual path to the Backup Exec Database file
  5. Start all Backup Exec services.
 

Was this content helpful?