SAP backups are failing to find the correct NetBackup shared library files.

Article: 100021137
Last Published: 2013-10-29
Ratings: 2 0
Product(s): NetBackup & Alta Data Protection

Problem

When running SAP backups, the backint.exe program may not be able to locate and load compatible versions of the needed shared library files.

Error Message

Unable to Locate Component
This application has failed to start because libnbclient.dll was not found, Re-installing the application may fix this problem.
 

Cause

This is most comonly due to having NetBackup installed in a non-default location on the client host.  Once the backint program has been copied to the ...\usr\sap\<SID>\sys\exe\run directory, it will check both the local run directory and the default NetBackup install directory on the C: drive for dependent dll files.  But since NetBackup is not installed in the default location, the files will not be located.

 

This can also occur if there is a failed or incomplete NetBackup installation.

 

Solution

1) Uninstall the NetBackup client/extension software fron the SAP client host.

 

2) Delete any residual copies of these files from all the disk drives.   This list may vary depending on the version of NetBackup installed.

 

backint.exe

libVnbat.dll

libnbbase.dll

libnbclient.dll (NetBackup 7.x or higher only)

netbackup.dll

vrtsLogFormatMsg_3.dll

vrtslogread_*.dll

vxACE_*.dll

vxcPBX.dll

vxicudt24l.dll

vxicuin24.dll

vxicuuc24.dll

vxiuuc24.dll

vxlis_*.dll

vxul_*.dll

xbsa.dll

 

3) Reinstall the NetBackup client software.

 

4) Perform a manual copy installation of backint per the NetBackup for SAP Administrator's Guide, e.g.

 

copy "j:\Veritas\NetBackup\bin\backint.exe" "d:\usr\sap\<SID>\sys\exe\run"

 

5) Review the PATH environment variable that is used by the SAP BR*Tools programs (i.e. brbackup, brarchive,brrestore) to ensure that it includes the ...\NetBackup\bin directory along with any other necessary system and application directories.   E.g.

 

SET PATH=J:\Veritas\NetBackup\bin;C:\Windows\system32 ...

brbackup -t online -m all ...

 

SAP backup and restore operations should then be successful.   If the backint.exe continues to fail to locate and load libraries, contact NetBackup Technical Services to trouble shoot the environment for any potential problem with the linking of library files with the backint.exe program.

 


Applies To

NetBackup for SAP
Windows platforms
 

Was this content helpful?