Backups are failing on Windows clients. The following error message will appear in the bpbkar log file on the client: "(TCP 10054: Connection reset by peer)" or "FTL - tar file write error (10054)".

Article: 100018361
Last Published: 2013-10-24
Ratings: 3 5
Product(s): NetBackup & Alta Data Protection

Problem

Backups are failing on Windows clients. The following error message will appear in the bpbkar log file on the client: "(TCP 10054: Connection reset by peer)", or "FTL - tar file write error (10054) ".

 

Error Message

Example, error messages from a client's bpbkar log:

(TCP 10054: Connection reset by peer)

FTL - tar file write error (10054)

 

Cause

The 10054 error is 'Connection Reset Error'. This is a Microsoft Winsock error.  It means that somewhere between the client and the server, the connection was reset.  Once the NetBackup software receives this error, it is unable to continue the backup. This error has been attributed to a variety of causes.

Here are some of the most common causes:

  1. A temporary disruption in the network communication 
  2. Bad network interface card (NIC) or cable on the client or the media server
  3. Bad NIC driver on any of the servers
  4. Faulty routers or routers that are not set to the correct duplex
  5. Other programs (applications) cause the NetBackup connection to drop
  6. TCP settings on any of the servers or network equipment

 

Solution

Here are some of the most common solutions:

  1. Obtain and install the latest Microsoft service pack for TCP / IP fixes.
  2. Ensure that the network settings are correct (NIC, Hub, Switch, Router, etc.).
  3. Ensure that the network settings are correct (the ports are set to full duplex VS half duplex and it is the same across the network. Avoid Autonegotiation if possible.
  4. Open the NIC hardware properties and verify it has the latest driver update provided by the NIC manufacturer website.
  5. In the NIC hardware properties > Advanced Tab, disable any lines that include the word 'offload' which is adding extra work to the NIC driver.
  6. Replace the NIC with a different brand or newer model.

 

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