Veritas System Recovery is not truncating Microsoft Exchange transaction logs during a backup.

Article: 100030285
Last Published: 2022-10-25
Ratings: 1 0
Product(s): System Recovery

Problem

When backing up with Veritas System Recovery (VSR), Microsoft Exchange transaction logs are not being removed (i.e. truncated) and they are filling up the drive.

Cause

This is often caused by the "Perform full VSS backup" option not being enabled in the backup job.  Additionally, VSR uses the Microsoft Volume Shadow Copy Service (VSS) to truncate the logs.  This issue can be caused when VSR is not able to properly communicate with the VSS writer for Exchange.

Solution

Confirm the "Perform full VSS backup" option is enabled in the Backup job:

1. Edit the Settings for the backup job

2. On the "Options" screen of the backup job, click the "Advanced..." button 

3. Check the box beside the option Perform full VSS backup and then click OK.  Proceed to click "Next" through the remaining job options screens and then click Finish to save the changes to the backup job.

 

If future backups do not truncate the Exchange transactions logs, there may be an issue with the Exchange VSS writer. Verify the writer status by doing the following;

-Open a command prompt as Administrator
-Type "vssadmin list writers" and press Enter
-Look for the writer named "Microsoft Exchange Writer"
-The status of this writer should be listed as "[1] Stable".

If the writer is not listed or is listed with a status other than "Stable", sometimes a simple reboot will cause it to start working again.

After a reboot if the writer is still not listed or the status is not stable, the Exchange VSS writer is not functioning properly.

 

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