VProTray.exe processes stop responding after users log off from a terminal server running Veritas System Recovery
Problem
After a few users log on and off of a terminal server running Veritas System Recovery, VPROTRAY.EXE process begins to accumulate memory usage and could eventually stop responding. Restarting the Veritas System Recovery service or the computer allows to run backups successfully until the issue reoccurs. Windows Task Manager shows an instance of VProTray.exe for each terminal user session.
Cause
When a user logs off from a terminal server where System Recovery is installed, the process VProTray causes multiple open processes and\or high memory usage and stops responding. Subsequently, the System Recovery service needs to be restarted to reset the process. This may cancel any backup jobs that are in progress.
Solution
Disable the VProTray process using the following procedure:
- Open the Registry Editor by going to Start > Run > regedit
- Browse to one of the following keys:
System Recovery 2013 and later:
HKLM | SOFTWARE | Microsoft | Windows | CurrentVersion | Run
System Recovery 2011 and earlier:
For 32-bit OS: browse to HKLM | SOFTWARE | Microsoft | Windows | CurrentVersion | Run
For 64 bit OS: browse to HKLM | SOFTWARE | Wow6432Node | Microsoft | Windows | CurrentVersion | Run
- Right-click on the appropriate regular string value listed below and select Modify:
Veritas System Recovery <version number>
Symantec System Recovery <version number>
Backup Exec System Recovery <version number>
System Recovery <version number>
- In the Value data field add REM at the beginning of the path and click OK.
Example:
"C:\Program Files\Veritas\Veritas System Recovery\Agent\VProTray.exe"
Should be changed to:
REM "C:\Program Files\Veritas\Veritas System Recovery\Agent\VProTray.exe"
- Reboot the server