MountV resource fails to offline and appears to hang in Veritas InfoScale for Windows

Article: 100017450
Last Published: 2022-07-27
Ratings: 0 1
Product(s): InfoScale & Storage Foundation

Problem

MountV resource fails to offline and appears to hang in Veritas InfoScale for Windows

Error Message

VCS WARNING V-16-10051-9023 MountV:MountResourceName_MountV: offline:Failed to lock volume [2:5]

Cause

By default, MountV resource cannot be taken offline if an open write handle remains on the volume.

%VCS_HOME%\log\MountV_A.txt log file will show if the resource has failed to lock the volume during offline.

Solution

All processes and applications which have open write handles to a volume must be stopped before MountV can go offline.  Microsoft's Handle.exe and Process Explorer tools can be used to find the process ID for any open handles that cannot be stopped gracefully.
 
The MountV resource may not respond to any further commands after getting hung in offlining status, including service group Flush.  When this occurs, a recycle of the cluster service is required before any new commands can be executed against the resource.
 
Follow the steps below on the node where the MountV resource is currently attempting to offline:
  1. haconf -dump -makero
    1. Saves and closes the cluster configuration
  2. hastop -local -force
    1. Stops the cluster service forcibly without getting the resources offline
  3. hastart
    1. Starts the cluster service

MountV resources will be back to an "Online" status with no pending actions.

Use Microsoft's Handle.exe or Process Explorer tools to determine which processes have open handles on the volume. Veritas Cluster Server (VCS) should be configured to stop any applications which are using the volume with proper dependency to go offline before MountV. 

MountV attribute ListApplications can be enabled to detect and log applications which have open handles during the offline operation. The handle details are logged in %VCS_HOME%\log\MountV_A.txt file.

***It is best to determine the underlying issue and address the root cause before proceeding with next steps***

In some cases, you may consider setting up the ForceUnmount attribute to ALL for the MountV resource, and retry the offline operation.

Warning: ForceUnmount = ALL results in a volume being taken offline forcibly even when a write handle exists. This may result in file system corruption and should be used with extreme caution under the direction of Veritas Support. Only enable this option if you are sure there are no applications or users writing to the volume, and have backups of data available to restore should it become unrecoverable. AutoFSClean attribute should be enabled where ForceUnmount = ALL to allow VCS to run CHKDSK against any filesystem reported as not clean during the next MountV online operation.

How MountV reacts to open handles depends on the value of the ForceUnmount attribute in the resource properties:

  • NONE: MountV will not go offline if any handle remains on the volume.
  • READ_ONLY: MountV will go offline if a read handle remains on the volume, but will not go offline if a write handle remains on the volume. (Default)
  • ALL: MountV will go offline if either a read or write handle remains on the volume.
 

Was this content helpful?