The NetBackup administrative console is unable to retrieve a server's version.

Article: 100011022
Last Published: 2017-11-27
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

Admin Console is unable to connect to the master server.

Error Message

Unable to retrieve version of the server xxx.xxx.xxx

Image

Cause

Checking the bpdbm log shows:

12:20:01.463 [25406] <4> bpdbm: VERBOSE = 0
12:20:01.465 [25406] <16> queryInvalidServerMsg: requestor xxx.xxx.xxx is not a valid server for query 223
12:20:01.472 [25406] <2> process_request: request complete: exit status 37 operation requested by an invalid server; query type: 223
This is due to the fact that the server running admin console has no SERVER entry in the bp.conf or in Registry of the master server - hence the authentication error.

Solution

Add:

SERVER = xxx.xxx.xxx

for Unix/Linux master's:

 <install path>/netbackup/bp.conf

or for Windows Master's:

run regedit and modify the registry path HKEY_LOCAL_MACHINE\SOFTWARE\VERITAS\NetBackup\CurrentVersion\Config string value "SERVER"

 

Make sure the master server can forward lookup xxx.xxx.xxx

Reverse lookup of the IP must also resolve to the same host xxx.xxx.xxx

Once the entry is added, the admin console should then be able to connect.

Another reason seen for this error was

The Client_Port_Window option was set to "1024 1024" - it should be set  to "0 0" which is the default. 

Once the entry is added, the admin console should be able to connect.  

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