Frequent BBU (Battery Back Up) failures. Full Capacity Charge "FCC" value set to 0%. A firmware update is required.

Article: 100009734
Last Published: 2013-07-26
Ratings: 0 0
Product(s): Appliances

Problem

Recurring BBU (Battery Back Up) failures are reported.

Failures persist through BBU replacement. 

Battery Replacement Required : Yes is displayed in BBU status output.

Error Message

The following output is generated from the BBU status command:
/opt/MegaRAID/MegaCli/MegaCli64 -adpbbucmd -aAll

BBU Firmware Status:
  Charging Status              : None
  Voltage                                 : OK
  Temperature                             : OK
  Learn Cycle Requested                  : Yes
  Learn Cycle Active                      : No
  Learn Cycle Status                      : OK
  Learn Cycle Timeout                     : No
  I2c Errors Detected                     : No
  Battery Pack Missing                    : No
  Battery Replacement required            : Yes
  Remaining Capacity Low                  : Yes
  Periodic Learn Required                 : No
  Transparent Learn                       : No
  No space to cache offload               : No
  Pack is about to fail & should be replaced : No
  Cache Offload premium feature required  : No
  Module microcode update required        : No

GasGuageStatus:
  Fully Discharged        : No
  Fully Charged           : No
  Discharging             : Yes
  Initialized             : Yes
  Remaining Time Alarm    : No
  Remaining Capacity Alarm: Yes
  Discharge Terminated    : Yes
  Over Temperature        : No
  Charging Terminated     : No
  Over Charged            : No

OR

Relative State of Charge: 0 %
Absolute State of charge: 0 %
Remaining Capacity: 0 mAh
Full Charge Capacity: 0 mAh
Run time to empty: Battery is not being discharged 
Average time to empty: Battery is not being discharged 
Average Time to full: Battery is not being charged 
Cycle Count: 6
Max Error = 100 %
Remaining Capacity Alarm = 120 mAh
Remining Time Alarm = 10 Min
Relative State of Charge: 0 %
Charger System State: 49168
Charger System Ctrl: 0
Charging current: 512 mA
Absolute state of charge: 0 %
Max Error: 100 %

The Firmware Term Log will show errors such as:
06/02/13 14:59:12:  Wrong FCC sensed in Battery, FCC = 1252
06/02/13 14:59:12: Disabled the Charging after resetting FCC
06/02/13 14:59:14: Written 0x0 at offset 0x38 on Gas Gauge        Read Back 0x0
06/02/13 14:59:14: FCC Successfully updated
06/02/13 14:59:15: Update of FCC in gas-gauge EEPROM Successful
06/02/13 14:59:16: Updated FCC Successfully
06/02/13 14:59:16: Enabling the Charging after resetting FCC

Cause

A defect has been identified in the RAID firmware stack which leads to Full Capacity Charge (FCC) Value being set and stuck at 0%.  This results in a BBU failure and controller switching to write thru mode.

Solution

A new Intel RAID controller firmware version 11.0.1-0057/1.41.372-2527 provides a fix which will prevent this issue from occuring.  This firmware update is now available in the following release update:

  • NetBackup Appliances 5200/5220 2.5.3

Download and README information is available in the Related Article linked below.

Workaround:
The firmware upgrade can be obtained by contacting Veritas technical support, referencing this document ID and one of the following Etracks:

  • For Appliances at version 2.0.3: 3227125
  • For version 2.5: 3227119
  • For version 2.5.1: 3227114
  • For version 2.5.2: 3227113

Note: After one of above binaries is applied, if for some reason the Appliance must later be reimaged with the 2.5.2 software, OR when an EEB is applied to a version below 2.5.2 and an upgrade to 2.5.2 or above is later performed, a firmware upgrade failure will be reported, as seen in this Figure (note red "failed" text):

This failure message does not affect the reimage or upgrade and can safely be ignored.

In the event that the BBU has failed and the Full Charge Capacity is permanently set to 0, the following steps must be taken:

  1. Apply the firmware update described above, either with an EEB or with a release update.
  2. Replace the BBU.
  3. Reboot the Appliance.

Please contact Veritas technical support for further assistance with a BBU replacement.

 

Applies To

This issue has been reported on NetBackup 5220 Appliances running version 2.0.3 or higher with firmware version 1.40.352-2004 or lower. 

References

Etrack : 3210625

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