Problem
Performing a catalog backup on a Master Server, either by policy or manually, can hang indefinitely.
The last line in the detailed status is:
Info bpdbm (pid=1234) staging <databasenme> backup to <StagingLocation>
No files are created in the staging folder.
Error Message
The nbdb log on the Master will show a last line that reads:
Windows:
01:02:03.410 [1234.4578] <4> backup_dbspaces: Executing: backup database directory 'C:\Program Files\Veritas\NetBackupDB\staging' wait before start with checkpoint log no copy transaction log truncate
UNIX/Linux:
01:02:03.040 [12345] <4> backup_dbspaces: Executing: backup database directory '/usr/openv/db/staging' wait before start with checkpoint log no copy transaction log truncate;
Cause
If there is a NetBackup process that is not starting normally, the failing process can cause the catalog backup to halt while the process tries to start.
Solution
Restart NetBackup Services.
Windows:
- Shut down NetBackup with command:
install_path\NetBackup\bin\bpdown -f -v
- Verify services stopped with command:
install_path\NetBackup\bin\bpps
- Restart NetBackup with command:
install_path\NetBackup\bin\bpup -f -v
UNIX/Linux:
- Shut down NetBackup with command:
/usr/openv/netbackup/bin/goodies/netbackup stop
- Verify services stopped with command:
/usr/openv/netbackup/bin/bpps -x
- Restart NetBackup with command:
/usr/openv/netbackup/bin/goodies/netbackup start
You can verify that the process is now working using:
Windows:
- Test NBDB online backup with command:
install_path\NetBackup\bin\nbdb_backup -dbn database_name -online destination_directory
UNIX/Linux:
- Test NBDB backup with command:
/usr/openv/db/bin/nbdb_backup -dbn database_name -online destination_directory
Note: Files will be visible in the target destination_directory.