Catalog backup on a Master Server can hang indefinitely

  • Modified Date:
  • Article ID:000087590

Problem

Performing a catalog backup on a Master Server, either by policy or manually, can hang indefinitely.
The last line in the detailed status is
Info bpdbm (pid=1234) staging <databasenme> backup to <StagingLocation>

No files are created in the staging folder.

Error Message

The "nbdb" log on the Master will show a last line that reads:
 

Windows:
01:02:03.410 [1234.4578] <4> backup_dbspaces: Executing: backup database directory '
C:\Program Files\Veritas\NetBackupDB\staging' wait before start with checkpoint log no copy transaction log truncate

Unix:
01:02:03.040 [12345] <4> backup_dbspaces: Executing:  backup database directory '/usr/openv/db/staging' wait before start with checkpoint log no copy transaction log truncate;

 

Cause

If there is a NetBackup process that is not starting normally, the failing process can cause the catalog backup to halt while the process tries to start.

Solution

Windows:
Shut down the NBU processes , verifying with the "bpps" command. 
bpdown -v -f
Then restart the processes:
bpup -v -f

Unix:
Shutdown the NBU processes, verifying with the bpps command
/usr/openv/netbackup/bin/goodies/netbackup stop
After this, restart the NBU processes using
/usr/openv/netbackup/bin/goodies/netbackup start


You can verify that the process is now working using:

Windows:
$inst_path\netbackup\bin\nbdb_backup -dbn database_name -online destination_directory

Unix:
/usr/openv/db/bin/nbdb_backup -dbn database_name -online destination_directory

Files will be visible in the target destination_directory

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