問題
C:\Windows\Installer ディレクトリに MSP または MSI が見つからないために Backup Exec の Hotfix または Service Pack がインストールできないことがある
エラーメッセージ
Bkupinst.htm に次のメッセージが表示されます。
V-225-136:The patch failed to install.Return code:1635 ***To search for information about this error, click here
MSI ログに次のメッセージが表示されます。
Local cached package 'C:\Windows\Installer\9ec0b.msi' is missing.
または
Couldn't find local patch 'C:\Windows\Installer\298dd2bd.msp'.Looking for it at its source
MSI デバッグを有効にするには、次の URL を参照してください。http://support.microsoft.com/kb/223300/ja
原因
MSI または MSP が Windows\Installer フォルダに見つかりません。
解決方法
手順 1) bkupinst.htm に、MSI や MSP が Windows\Installer フォルダに存在しないというメッセージが表示される場合、次より参照して検索します。
bkupinst.htm ログの場所:C:\Documents and Settings\All Users\Application Data\Veritas\Backup Exec\Logs
手順 2) MSI または MSP が前述の bkupinst.htm ログの場所で検索できない場合、次の Microsoft サポート技術情報の記事に記載されている方法に従ってレジストリから MSI ログを有効にします。https://support.microsoft.com/kb/223300/ja
手順 3) MSI ログに MSI が見つからないと表示される場合は、ソフトウェア DVD を入手しており、インストールが可能であることを確認します。
手順 4) MSI ログに MSP が見つからないと表示される場合は、見つからないまたは破損していると報告された MSP をレジストリで検索します。
MSP のみを使用して Backup Exec Hotfix 番号をレジストリで検索する方法
Backup Exec 製品の GUID の検索
警告: Windows レジストリエディタを誤って使用すると、サーバーオペレーティングシステムが正しく機能しなくなる可能性があります。Windows レジストリを変更する際は十分に注意してください。レジストリエディタのアプリケーションの操作に習熟したユーザーだけがレジストリの修正を行うようにし てください。レジストリに変更を加える前に、レジストリとワークステーションの完全なバックアップを行うことを推奨します。
レジストリエディタを開いて次の場所に移動します。
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\ ここで Products の下にある各 GUID をハイライトして Backup Exec の GUID を見つけて記録します。
手順 1) MSP がある GUID を記録します。レジストリ内の次の場所にあります。
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Patches 各 GUID を調べて、消失している MSP が表示される GUID を見つけます。(GUID を記録します)
手順 2) 手順 1 で記録した GUID を使用して検索し、Hotfix 番号を見つけます。このレジストリは次の場所にあります。
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\<製品の GUID>\Patches
手順 3) この Hotfix をシマンテック社のサポート Web サイトからダウンロードして解凍します。解凍したファイルの bepatch.msp を見つからない msp の名前 (MSI ログ内で使用されている名前) に変更します。たとえば、bepatch.msp を 298dd2bd.msp (MSI ログで見つからないとされている MSP) に名前変更します。この MSP を windows\Installer ディレクトリにコピーします。
Hotfix または Service Pack のインストールを再実行し、完了します。
前述の手順を実行しても問題が解決しない場合は、シマンテックテクニカルサポートに連絡してください。