Status code 2009 during tape backup

Article: 100007799
Last Published: 2019-06-08
Ratings: 4 9
Product(s): NetBackup & Alta Data Protection

Problem

Backup jobs directed to a local storage unit mount the tape in the tape drive but NetBackup does not report the tape as mounted. The backup job eventually fails with status 2009.

Tape cartridge is then stuck in the tape drive and must be manually dismounted.

The OS tape drive configuration compares properly to the NetBackup device configuration as reported by 'scan' and 'tpconfig'. The 'robtest' utility will successfully dismount the tape drive.

Note: These 3 commands can all be located in the following directory...
    UNIX/Linux: /usr/openv/volmgr/bin/
    Windows: install_path\Volmgr\bin\

Running the 'Configure Storage Devices' wizard does not resolve the problem.

Error Message

All compatible drive paths are down but media is available All configured drives that can be used for this job are down.

Cause

There may be multiple causes to these types of issues, here are two potential options...

  • Option 1: Suspect issues with the robotic library no functioning properly, or...
  • Option 2: There may be a non drive path error for the tape drive in EMM.

Solution

There may be multiple solutions to these types of issues, here are two potential options...

Option 1: Power cycle (reboot) both the problematic robotic library and the master-media server it is attached to in the proper order:

  1. Power down the media server(s) and then the primary/master server.
  2. Power down the robotic library. Suggest keeping it down for 5+ minutes.
  3. Power up the robotic library, then wait for it to be fully initialized and 'online'.
  4. Power up the primary/master server and then the media server(s).
  5. Test that the robotic library is now functioning properly again.

Or...

Option 2: Remove and recreate the device record from EMM.

  1. Remove the tape drive from the NetBackup configuration.
  2. Restart the NetBackup Device Manager service.
  3. Run the 'Configure Storage Devices' wizard.
  4. Check that the tape drive has returned to use afterwards.

Was this content helpful?