Licensing errors continue to appear, even after running "vxkeyless set NONE."

Article: 100025663
Last Published: 2013-07-17
Ratings: 1 0
Product(s): InfoScale & Storage Foundation

Problem

Messages continue to indicate that keyless licensing is enabled, even after runnining "vxkeyless set NONE." WARNING V-365-1-1 may also be reported.

 

Cause

This behavior occurs if /etc/vx/licenses/lic/.keyless.diff is missing. This file is required to record changes to the vxkeyless mode.

 

Solution

Follow these steps to work around this issue, :

1. Back up the contents of /etc/vx/licenses/lic/. A procedure for this can be found here: How to remove keyless licensing and revert to permanent license keys on InfoScale products

2. Delete the *.vxlic files that are stored under /etc/vx/licenses/lic/.

3. Use vxlicinst to add the permanent keys. An example of using vxlicinst can be found here: How to remove keyless licensing and revert to permanent license keys on InfoScale products

4. Reinitialize the licenses. A procedure for this can be found here: How to remove keyless licensing and revert to permanent license keys on InfoScale products


Note: /etc/vx/licenses/lic/.keyless.diff can be recreated, if needed, by re-enabling keyless mode.

 

 

 

Was this content helpful?