Backup Throttling not working for a DLO Agent

Article: 100024165
Last Published: 2013-05-02
Ratings: 0 0
Product(s): Desktop Laptop Option

Problem

In both NetBackup Desktop Laptop Option (DLO) and Veritas DLO it is possible to configure a Profile to perform backup jobs at a reduced speed by slowing down the transfer rate of data to the Network User Data Folder (NUDF).  This is called Throttling.

Throttling may be desired if the total network bandwidth between the Desktop Agent and the NUDF is restricted or shared by many users.   If running unthrottled, other users may experience slow network responsiveness due to an active DLO Agent backup job on someone else desktop using all of the network bandwidth.

Sometimes, after configuring Throttling, some DLO Agent backups continue unthrottled.

Error Message

No error message is generated.

Cause

There are several known causes which result in DLO Agents running unthrottled jobs.

Solution

1. Improperly Configured Throttling settings - When the DLO Agent starts up, it dynamically analyzes which Throttling "bucket" the current Agent session falls into.  There are 3 "buckets" Low network speed, Medium network speed and High network speed.   Often, the DLO Agent will decide on a "bucket" which was not configured in the Profile.

The DLOClient.log file at "Verbose Logging" will document which bucket the session falls into:
T> reconciler.cpp( 6523 ) THROTTLING_LOG: (Backup Throttling) Network bandwidth based on hardware configuration is 400000000 bits per second.
T> reconciler.cpp( 6539 ) THROTTLING_LOG: (Backup Throttling) Current Bandwidth of NIC lies in High Bucket.

Resolution:  
Be sure the correct "bucket" has been configured for Throttling in the Profile for the DLO Agent in question.


2. Corrupt Performance Monitor Environment - When the DLO Agent starts up and analyzes which "bucket" the session will fall into, it looks at many things.  Among the things it looks at are Performance Counters of specific Performance Monitor Objects. Specifically certain counters under, Performance Objects "Logical Disk" and "Network Interface".   If the DLO Agent is unable to tap into these particular performance counters, it will be unable to determine if it needs to throttle the data stream.

The DLOClient.log file at "Verbose Logging" may document these errors during the analysis:

E> diskthrottle.cpp( 234 ) failed to get disk queue length: E0140007
E> perfdata.cpp( 250 ) did not find performance object LogicalDisk

 

E> perfdata.cpp( 250 ) did not find performance object Network Interface
E> netstats.cpp( 118 ) failed to get NIC read rate (or instances changed): E0140007
 
Resolution:
It is required to have a healthy Performance Monitor environment on the DLO Agent in question.  It may be possible to determine if these Performance Objects exist by launching Performance Monitor (perfmon) on the desktop and attempting to add counters from the objects in question.  If either the counters or objects do not exist, this will have to be fixed before the DLO Agent can properly perform Throttling.
 

3. Corrupt WMI Environment - When the DLO Agent starts up and analyzes which throttling bucket to classify the session into, it attempts to identify what the settings are on the Network Cards in the local host - things like NIC speed, NIC duplex settings.  In order to do this, it makes a call to Windows Management Instrumentation (WMI) environment on the host. 
 
If the call to the WMI environment fails, the DLOClient.log file may document these errors during the analysis:
E> netadapterhandler.cpp( 27 ) THROTTLING_LOG: Unable to connect to namespace root\WMI. Error : -2147217388
E> reconciler.cpp( 6519 ) THROTTLING_LOG: (Backup Throttling) Failed to retrieve network bandwidth from hardware configuration.80004005
 
Resolution:
If the above error is persistent, it may be necessary to engage Microsoft to evaluate and repair the WMI environment on the machine running the DLO Desktop Agent.

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