SQL Backup fails with error "Final error: 0xe0008443 - One or more SQL Database consistency checks have failed"
Problem
SQL Backup fails with error "Final error: 0xe0008443 - One or more SQL Database consistency checks have failed
"
Error Message
Final error:
0xe0008443 - One or more SQL Database consistency checks have failed.
Final error category: Resource Errors
For additional information regarding this error refer to link V-79-57344-33859
Errors:V-79-57344-65085 - There was a problem running the DBCC.
The job log might also report the following error:
"An unknown or unexpected database error occurred while attempting a DBCC
."
ORV-79-57344-65085 - Database 'Database Name' cannot be opened due to inaccessible files or insufficient memory or disk space. See the SQL Server error log for details
.
ORV-79-57344-65085 - The Server principal is not able to access the database "Database Name " under the current security context.
ORV-79-57344-65085 - There was a problem running the DBCC. [DBNETLIB][ConnectionRead (recv()).]General network error. Check your network documentation.
Cause
There are different possible causes like:
- The Database being backed up is not online or cannot be accessed.
- The Backup Exec Service account has insufficient privileges to access SQL databases.
- The SQL Service account, if different to the Backup Exec Service account, has insufficient rights to the location of the SQL databases.
- There is actually a consistency issue with the database.
- The database is in single user mode and is already open in another application or in SQL Management Studio.
Solution
Please verify each point of these solutions:
1. Verify that the database in question is online. If the database is not online, it will need to be online for backups.
2. Verify the database can be accessed via SQL Management Studio
3. Verify that the Backup Exec Service account has enough privileges:
a) Open SQL Management Studio
b) Connect to the Instance>Security>Logins
c) Verify if the Backup Exec account or the account used for the SQL backup in listed
- If it is not found, add it and give it Sysadmin role
- If it is already present, ensure it has Sysadmin role assigned
d) On the same "Select a page" option, select "User Mapping"
- Under "Users mapped to this login", select "master" database
- Under "Database role membership for: master", select "db_datareader" and "db_datawriter"
4. Verify the the SQL Service account has enough rights to the location of the database(s)
a) Open Explorer and go to the location where the database(s) are stored
b) Open the Properties - Security tab of that folder and ensure that the SQL Service account has Full Control rights
5. Verify that the DBCC command works outside of Backup Exec
For more info how Backup Exec interacts with DBCC see: https://www.veritas.com/content/support/en_US/article.100031237
a) Open SQL Management Studio
b Click on "New Query"
c) Type the following commands and click on "Execute"
use DatabaseName
dbcc checkdb
Note: DatabaseName is the name of the database that is visible in the Job log of the failed SQL job.
6. Verify what user mode is configured:
a) Open SQL Management Studio
b) Go to the Database Properties of the failing database.
c) Verify under the 'Options' page, the 'Restrict Access' setting under the 'State' heading which should be MULTI_USER.
If the setting is SINGLE_USER the backup may fail.
Changing the setting to MULTI_USER will enable backups even if connections are open.