Warning "Snapshot provider error 0xe0008526. Backup Exec could not locate a VSS software or hardware snapshot provider for this job."

Article: 100000866
Last Published: 2023-09-22
Ratings: 2 7
Product(s): Backup Exec

Problem

Backup Exec is unable to locate snapshot providers installed on the computer.

 

Error Message

V-79-57344-34086 - AOFO: Initalization failure on: "C:". AOFO used: Microsoft VSS. Snapshot provider error 0xe0008526: Backup Exec could not locate a VSS software or hardware snapshot provider for this job. Select a valid VSS snapshot provider for the target computer.

Application Log :

Log Name: Application
Source: VSS
Event ID: 7001
Computer: <Servername>
 

Description:
VssAdmin: Unable to create a shadow copy: The volume shadow copy provider is not registered in the system.
Command-line: 'C:\Windows\system32\vssadmin.exe Create Shadow /AutoRetry=15

C: Drive properties window shows error about VSS Provider:

1. Go to Windows Explorer

2. Right click on C: drive

3. Click " Shadow Copies" tab.

4. Check for this error:

Initialization Failed:

Error: 0x80042304 : The volume shadow copy provider is not registered in the system.

UMI Code: V-379-34113

 

Cause

The snapshot provider selected for the backup job is not installed on the server being backed up.

 

Solution

1.  Check that snapshot providers are installed on the system being backed up.

  • Open a command prompt.
  • Type "vssadmin list providers"
  • If nothing is returned, then there is most likely an issue with VSS that will most likely need assistance from Microsoft to resolve.
    • You can also verify that VSS is properly registered by checking the following registry key:
      •  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\VSS\Providers\{b5946137-7b9f-4925-af80-51abd60b20d5}
  • If writers are not listed or show they are in an error state, reboot the server and run the command again.
 

2.  Configure the backup job to use a specific snapshot provider.
  •  Edit backup job.
  •  Navigate to Advance Open File.
  •  Confirm "Use snapshot Technology" option is checked.
  •  Select the appropriate snapshot provider - "System-Use Microsoft Software Shadow Copy Provider" from the drop down menu is typically best.
   
 

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