M365 Exchange Online personal archive mailbox restore fails when restored to the same location

Article: 100076695
Last Published: 2026-02-10
Ratings: 0 0
Product(s): Backup Exec

Problem

M365 Exchange Online personal archive mailbox restore fails when restored to the same location

Error Message

SaaS Connector Framework error: 67113865/109. Cannot find the specified Mailbox.
 

Cause

When an on-premise Exchange mailbox is migrated to Microsoft 365 Exchange Online, restoring that personal archive mailbox to the same mailbox on M365 is not possible.
 

Solution:

Workaround

Perform a redirected restore of personal archives to another mailbox.

At this time, there are no plans to address this issue through a patch or hotfix in the current or previous versions of the software. Although this issue may potentially be resolved in a future major revision, it is not currently scheduled for any upcoming release. If this issue has a significant business impact on your continued use of the product, please contact your Sales representative or the Sales team to discuss your concerns.

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