Unable to browse or backup the public folder in Microsoft 365. The following error is seen during browse "Public folder administrator credentials were not configured for the operation"
Problem
Unable to browse or backup the public folder in Microsoft 365. The following error is seen during browse "Public folder administrator credentials were not configured for the operation"
Error Message
Browsing the Public Folder from the Microsoft 365 backup job selection shows the following error "Unable to browse or backup the public folder in Microsoft 365. The following error is seen during browse "Public folder administrator credentials were not configured for the operation"
Cause
The correct account which has priveledges to backup Microsoft Public Folders is not used.
Solution
1. Note the account which has root permission for public folder.
2. If the account is not setup for public folder , then assign one of the Microsoft 365 users root permissions from Microsoft 365 admin site.
3. In Backup Exec, right click on Microsoft 365 tenant from the Backup and Restore tab and click on update. Choose "Update public folder administrator" and click Next. Use the public folder administrator account in step 2 and run through the wizard.
4. Review the backup selections again and if the browse works then create a backup to ensure it can be backed up successfully.