For Infoscale Operations Manager 9.0, deploying an agent-based Windows Managed Host (MH) fails with an error: "Unable to determine Administrators group name"
Problem
For InfoScale Operations Manager (IOM) 9.0, deploying an agent-based Windows Managed Host (MH) fails.
Error Message
The errors below are seen in C:\ProgramData\Symantec\VRTSsfmh\logs\mhrun.log
Component:"configure_ch", Message:"["C:\windows\System32\wbem\WMIC.exe" group where sid="S-#-#-##-###" get name /value] returned error [12800]"
Component:"configure_ch", Message:"Unable to determine Administrators group name"
Cause
By default, WMIC calls are used to retrieve information for the Administrators group name. This issue can occur if these WMIC calls are blocked/not allowed. This causes the configure_ch (Control Host) component to fail, thereby preventing the Infoscale Operations Manager Host Component (VRTSsfmh) agent from being deployed on a Windows machine.
Note #1: By default, InfoScale installs the VRTSsfmh agent with every install of InfoScale. The above error only applies when attempting to add a Windows Server as a MH on which this agent was previously removed.
Note #2: Attempting to add a Windows Server as an agentless host to the IOM Server will not report this error.
Solution
A hotfix is now available for this issue in the current version(s) of the product(s) mentioned. Refer to the Hotfix link under Related Articles to obtain the hotfix needed to resolve the issue.
Attempt to add the impacted Windows Servers as an agent-based MH, once the patch is applied.