Disaster Recovery emails fail to deliver on NetBackup Appliances and RedHat primary servers, when multiple email recipients are configured
Problem
When defining multiple email recipients in the NetBackup catalog backup policy 'Disaster Recovery' section, the NetBackup documentation suggests commas are used to separate the email addresses.
If the comma separated email addresses are defined, no email is sent, depending on the operating system version of the primary server.
This has been noted on NetBackup Appliances (Flex instances), where the mail tool s-nail is configured.
Error Message
There is no error message, but the email with the Disaster Recovery files is not sent.
Cause
From RedHat 9.x the s-nail mail tool is configured and it does not support the use of commas to separate the email addresses.
RedHat version 8.x may also experience the same problems as s-nail was not standard but could be installed as an extended feature. For example, the NetBackup Flex instances using RedHat 8.10 have the s-nail mail tool installed.
The previous version of the mail tool (mailx) allowed comma separated email addresses.
Solution
If multiple email addresses are defined in the NetBackup catalog backup policy, ensure the email addresses are separated with a space.
The NetBackup Java GUI and Web UI will allow multiple email addresses to be applied and saved with a space instead of a comma. It should be noted, the Web UI will suggest addresses are invalid, but this is a warning and does not prevent the policy from being saved, but importantly this allows the multiple email address recipients to receive the NetBackup catalog disaster recovery files.
Below is an example of applying two email addresses with a space as a separator; please ignore the warning message.