NetBackup Windows client upgrades to NetBackup 11 using vxupdate fail Status 7272

Article: 100075292
Last Published: 2025-09-12
Ratings: 0 0
Product(s): NetBackup

Problem

Upgrading NetBackup Windows clients using the Deployment Management tool (vxupdate) to NetBackup 11.0.0.1 can fail with STATUS 7272, when anti-virus or malware software is scanning the NetBackup directory structure on the client.   

Problem affects earlier versions of the vxupdate package vxupdate_nb_11.0.0.1_windows_x64.sja

 

Error Message

Deployment job details:

Error nbpem (pid=10632) backup of client <CLIENT-NAME> exited with status 7272 (The preinstallation checks failed.)

Client install log:

<2> The nbcheck test about to execute is: [<CLIENT-NAME>].
<2> Space needed to transfer packages: 716.74 MB.
<2> Space needed to extract packages: 1.12 GB.
<2> Executing ["C:\Program Files\Veritas\NetBackup\Temp\nbprechecker_11.0.0.1_windows_x64.sja.sja.extracted\nbcheck.exe" --keepgoing --test=<CLIENT-NAME> --test=vxupdate_space_check --define vxupdate_tmp_space_needed=1954042979  2>&1]...
<2> Execution finished.
<2> nbcheck produced the following output:
<4> --------------------------------------------------------------------------------
<4> The system cannot execute the specified program.

<4> --------------------------------------------------------------------------------
<2> nbcheck output finished.
<2> nbcheck finished with status [1].
<2> Trying to cleanup temp...
<2> Performing backlevel check on binary [nbinstallagent.exe], found backlevel=false
<2> (CLEANUP) Working in directory [C:\Program Files\Veritas\NetBackup\Temp\nbprechecker_par.2712]
<2> (CLEANUP) Trying to delete [C:\Program Files\Veritas\NetBackup\Temp\nbprechecker_par.2712]
<2> (CLEANUP) Trying to delete [C:\Program Files\Veritas\NetBackup\Temp\nbinstallagent_conffile]
<2> (CLEANUP) Trying to delete [C:\Program Files\Veritas\NetBackup\Temp\nbinstallagent.exe]
<2> (CLEANUP) Trying to delete [C:\Program Files\Veritas\NetBackup\Temp\client_config.exe]
<2> (CLEANUP) Trying to delete [C:\Program Files\Veritas\NetBackup\Temp\nbliveup.exe]
<4> EXIT STATUS 7272

 

Cause

The nbcheck.exe binary was flagged by the Windows Defender as malware, which would remove the suspected file causing the installion to fail.

 

Solution

The NetBackup engineering team were made aware of the issue and in the NetBackup release after NetBackup 11.0.0.1, the nbcheck.exe binary will be digitally signed to avoid the problems from occurring in future.   Note, the latest version of NetBackup 11.0.0.1 vxupdate Windows package is available from the download centre, this should have the updates included to avoid the problems.

Workarounds exist, such as manaully installing/upgrading the Windows NetBackup client and not using the Deployment Management option.  However, as per the NetBackup recommendations, it's advised to exclude and prevent anti-virus and malware scanner tools from scanning the location where NetBackup is installed, which would aoid experiencing the install/upgrade problems.   For further details search for  General recommendations for virus scanner exclusions working with NetBackup.

There are currently no plans to address this issue through a patch or hotfix in the current or previous versions of the software. However, it is scheduled to be resolved in the next major product revision. Please note that the product engineering team reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests. Our plans are subject to change, and any actions you take based on this information, or your reliance on it, are at your own risk.

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