After manual DR restore for Windows 2025 and post system reboot, when user logs in, it ends up seeing a black screen.

Article: 100074698
Last Published: 2025-09-25
Ratings: 0 0
Product(s): Backup Exec

Problem

After manual DR restore for Windows 2025 and post system reboot, when the user logs in, it ends up seeing a black screen. 

 

Error Message

No error messages as such, but the following error events will be seen for – Explorer.exe and ShellHost.exe 

 

Faulting application name: Explorer.EXE, version: 10.0.26100.4202, time stamp: 0x9b0b995a 

Faulting module name: Explorer.EXE, version: 10.0.26100.4202, time stamp: 0x9b0b995a 

Exception code: 0xc0000409 

Fault offset: 0x00000000000dcd1e 

Faulting process id: 0x1B4C 

Faulting application start time: 0x1DBE65CC61B73AF 

Faulting application path: C:\WINDOWS\Explorer.EXE 

Faulting module path: C:\WINDOWS\Explorer.EXE 

Report Id: a2727054-630b-4fe5-b170-1e61413f5a62 

Faulting package full name: 

Faulting package-relative application ID: 

  --------------------------------------  

Faulting application name: ShellHost.exe, version: 10.0.26100.4202, time stamp: 0xaca3f020 

Faulting module name: ControlCenter.dll, version: 0.0.0.0, time stamp: 0xf77347ae 

Exception code: 0xc0000409 

Fault offset: 0x0000000000128876 

Faulting process id: 0x2340 

Faulting application start time: 0x1DBE65AF130FB9E 

Faulting application path: C:\Windows\System32\ShellHost.exe 

Faulting module path: C:\Windows\System32\ControlCenter.dll 

Report Id: 12da3859-87ce-4e5d-9272-3e543de031c2 

Faulting package full name: 

Faulting package-relative application ID: 

 

Cause

Windows 2025 has brought some security related changes in the App-x area. As a result, post restore, App-x registration does not happen automatically, like earlier Windows Operating system versions.  Hence, one needs to do App-registration explicitly again. 

 

Solution

  1. Press Crtl+Alt+Delete and select the “Task Manager” option. Once the Task Manager opens up, open Windows “Run box” using an option available there. And from “Run box”, invoke Windows CMD shell prompt. 

 

** Sometimes, it may take a long time to open the “Task Manager”. 

 

  1.  From CMD shell prompt, launch Powershell.exe with Admin privileges 

i.e Go to - C:\Windows\System32\WindowsPowerShellv1.0\  and run Powershell.exe 

 

  1. Run the command -  Set-ExecutionPolicy Unrestricted -force

 

  1. Run the following command /script 

For Administrator:

---------------------------------------------------------------
 Get-AppXPackage -AllUsers | ForEach-Object {
    Try {
        Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"
    } Catch {
        Write-Host "Failed to register: $($_.Name)"
    }

Start-Process explorer.exe
---------------------------------------------------------------

 

For existing users:

Launch Powershell using Admin privileges using following command

Start-Process powershell -verb RunAs

under pop up please provide Built-in Administrator's credentials and run the below script 

---------------------------------------------------------------
Get-AppxPackage | ForEach-Object {
    Try {
        Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"
    } Catch {
        Write-Host "Failed to register: $($_.Name)" -ForegroundColor Yellow
    }
}

Start-Process explorer.exe
---------------------------------------------------------------

5. Launch  “explorer.exe” 

This will get the user logged in to his desktop profile. And all the system apps would work seamlessly. 

 

**Please note that, upon executing the PowerShell script, it does show exceptions/errors in red color and that is OK and that won't have any impact on the restored system. 

** To avoid errors in typing 4th command syntax, it is advised to copy this content/script and create a PowerShell file(.ps1) and place it on the file system prior conducting manual DR restore.

** Note that the above procedure needs to be repeated for each user profile exists on the box inorder to load corresponding users desktop profile.

 

Note : Steps provided here ONLY works for Backup Exec 25.1 and above versions.If user has BE version prior BE 25.1, then they must upgrade it to BE 25.1 version first and they must take a new/fresh System state backup . And from that new backup set only these steps will work for Manual DR recovery on Windows 2025 machines .These steps won't work for the backup sets taken prior BE 25.1.

 

References

Etrack : 4188146

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