Errors "Error EBABOBEE: Operating System API" and "Error 00000002: The system cannot find the file specified." pop up during the restore process.

Article: 100074223
Last Published: 2025-04-23
Ratings: 0 0
Product(s): System Recovery

 

Problem

During a system recovery process using the Restore Anywhere (RAO) option, the recovery fails with the error message: "Error EBABOBEE: Operating System API" and "Error 00000002: The system cannot find the file specified". The issue occurs when attempting to restore a complete system backup to a server with different hardware. 

 

Error Message

Error EBABOBEE: Operating System API
[RegistryOperations:-GetinfoFromRegistry] RegQuery/ValueExW(TARGET-HIVE_SOFTWARE\Microsoft|Windows NT|CurrentVersion, RegisteredOwner) failed."
Error 00000002: The system cannot find the file specified.

 

Figure 1

Cause

The issue happens while restoring the recovery point where there is no "RegisteredOwner" registry key in the backed C drive with enabling Restore Anyware option. In general, this issue is more likely to occur when restoring to a system with different hardware or configurations.

 

Solution

Workaround:

To resolve the issue, recommend to perform either A or B as workarounds:

A. Restore without Restore Anyware option

B. Restore with Restore Anyware option after adding the missing registry key "RegisteredOwner" and backing up again.

  1. On the original machine, run "regedit".
     
  2. Browse HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
     
  3. Right-click CurrentVersion and select [New] [String Value].
     
  4. Rename New Value #1 to RegisteredOwner.
  5. Input "Windows User" or end user's name like Figure 2.

    Figure 2

  6. Back up the entire system.
     
  7. Use the "System" recovery option and select the updated .sv2i file.

 

 

 

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