After User Principal Name change, end users are unable to download SharePoint items from End User Portal.

Article: 100069043
Last Published: 2024-07-25
Ratings: 0 0
Product(s): Veritas Alta SaaS Protection

Problem

Under certain circumstances, Alta SaaS Protection (ASP) fails to merge a user's User Principal Name (UPN) and their new email (SMTP) addresses into their user Identifiers. 

Two accounts may be observed for the same user in Admin Portal.  One is set as an Internal account type and the other as an External account type.

  • External - Identifiers for the external account will contain only an SMTP Address and will not appear as a Directory Provider Account:

  • Internal - Identifiers for the internal account will contain multiple entries for additional SMTP Addresses and SID and will appear as a Directory Provider Account:

By design, external users cannot download/access SharePoint data from ASP.

 

Error Message

When trying to open a SharePoint stub the following error is seen in the web browser: 

Error executing retrieveLatestItemVersionBlobStreamInternal. The currently authenticated principal ('example.user1@contoso.com', ID: XXXXXXXX) does not have access to item ID XXXXXXX in stor ID X .

 

Cause

This occurs when Directory Synchronization is configured and it finds 2 accounts in the tenant with the same principal identifier but is unable to merge the accounts. 

Since only internal account types in ASP can retrieve the SharePoint stubs and the accounts haven't been merged yet, the error occurs, and fails to download the item.

 

Solution

This issue is currently under investigation by Veritas Technologies LLC. Pending the outcome of the investigation, this issue may be resolved by way of a patch or hotfix in current or future revisions of the software. However, this particular issue is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns.

Note: Customers experiencing this issue are encouraged to contact Veritas Technical Support as data is still being collected to assist in resolving this issue.

 

References

JIRA : HM-22879 JIRA : DAS-3448

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