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Backups of Exchange Online mailboxes fail when using PowerShell Management API

Article: 100065369
Last Published: 2025-07-09
Ratings: 0 0
Product(s): Alta SaaS Protection

Problem

Backups of Exchange Online mailboxes fail when using PowerShell Management API.

Error Message

The error below can be seen in the connector logs. 

Error executing job Backup Location 'Connector Name'.

Error initializing connector for backup.
Error creating O365 PowerShell runspace.
Error creating Exchange PowerShell runspace with configuration: AppReg( AppID:6df9c43f-xxxx-xxxx-xxxx-d355908ce55f )
The role assigned to application 6df9c43f-xxxx-xxxx-xxxx-d355908ce55f isn't supported in this scenario. Please check online documentation for assigning correct Directory Roles to Azure AD Application for EXO App-Only Authentication.
The role assigned to application 6df9c43f-xxxx-xxxx-xxxx-d355908ce55f isn't supported in this scenario. Please check online documentation for assigning correct Directory Roles to Azure AD Application for EXO App-Only Authentication.

 

Cause

To backup soft deleted mailboxes, the application used for authentication doesn't have enough permission. 

Solution

Assign Exchange Administrator permission to the application used for authentication on the connector. 

1. Navigate to Entra ID > Roles & Admins

2. Search for Exchange Administrator

3. Click Add assignments

4. Select No member selected

In the search find the App that requires the Role and add the Role to it.

 

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