NetBackup IT Analytics - Oracle quarterly security patch failed with error code = 73 (Windows)

Article: 100063415
Last Published: 2024-07-24
Ratings: 0 15
Product(s): NetBackup IT Analytics, NetBackup & Alta Data Protection

Problem

The following error may occur when attempting to apply the Oracle quarterly security patch on a Windows server.
 

Error Message

Following active files/executables/libs are used by ORACLE_HOME :c:\opt\oracle
c:\opt\oracle\bin\ORAEVRUS19.dll

UtilSession failed: Prerequisite check "CheckActiveFilesAndExecutables" failed.
Log file location: c:\opt\oracle\cfgtoollogs\opatch\opatchYYYY-MM-DD_HH-MM-SS_1.log

OPatch failed with error code = 73
 

Cause

The error message indicates that some files or executables within your Oracle Home directory are currently in use. Specifically, the file ORAEVRUS19.dll is active.

Found in the log c:\opt\oracle\cfgtoollogs\opatch\opatch<date>_<n>.log 

Following active files/executables/libs are used by ORACLE_HOME :c:\opt\oracle
c:\opt\oracle\bin\ORAEVRUS19.dll

 

Solution

Verify Oracle was shutdown:

1) Ensure the database and listener services running from the specified $ORACLE_HOME are cleanly shut down.

  • Confirm that no user processes are accessing any files within the Oracle Home.

2) Check Active Files:

  • c:\opt\oracle\bin\ORAEVRUS19.dll

  • Identify any processes or services that might be using these files.

3) Investigate Dependencies:

  • Determine which processes or applications rely on ORAEVRUS19.dll.
  • Investigate whether any other software or services are using this DLL.

4) Retry applying the Oracle patch:

  • Once you’ve ensured that no active processes are using the specified files, retry the operation.

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