Email alerts no longer work after you make changes on the Alert Configuration page of the NetBackup Appliance Web Console

Article: 100061042
Last Published: 2023-11-27
Ratings: 0 0
Product(s): Appliances

Problem

On NetBackup Appliance 5.3, email alerts no longer work after you make changes and click Save on the Alert Configuration page of the NetBackup Appliance Web Console.

Error Message

The following message displays after you click Save:

Failed to send a test email. Please verify that the SMTP server and the email configuration are correct for this appliance.

The following message displays if you run the Email Test command in the NetBackup Appliance Shell Menu:

CLISH > Alerts > Email Test 
Sending test email to software email address failed. Software email address has no response. Check the network connections, the SMTP settings and the software email address of your appliance. If no problem is found, contact your system administrator for more assistance.
Sending test email to hardware email address failed. Hardware email address has no response. Check the network connections, the SMTP settings and the hardware email address of your appliance. If no problem is found, contact your system administrator for more assistance.

The following error is logged into /log/autosupport/alertmanager.log the  file:

2023-11-03T10:23:58.721+08:00 INFO  [ListenerThread-3] EmailController - STMP Subject: Hardware admin test email SMTP Message ID: <221636374.19.1698978238720@FQDN>
2023-11-03T10:24:04.228+08:00 ERROR [ListenerThread-3] EmailController - V-475-2-1100: Error encountered sending Alert email to hadmin_FQDN: Authentication failed; nested exception is javax.mail.AuthenticationFailedException: 535 5.7.8 Error: authentication failed: UGFzc3dvcmQ6

Cause

After you click Save, the appliance mistakenly overwrites the previously configured SMTP password with the secure view that displays on the page ('**********').

Solution

Perform the following steps:

  1. Log in to the NetBackup Appliance Web Console and navigate to the Settings > Notifications > Alert Configuration page.

  2. Type the correct password in the SMTP password field, then click Save again.

  3. To verify that the issue is resolved, rerun the Email Test command in the NetBackup Appliance Shell Menu.

References

JIRA : NBA-13689

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