Problem
The Enterprise Vault (EV) Indexing Service fails to start after moving the Vault Service Account (VSA) temp folder location.
Error Message
The following Events will occur in the Enterprise Vault Event Viewer log.
Event ID: 41312 The Elasticsearch Indexing Engine could not complete all the required startup routines: Failed to start Elasticsearch JVM. Service will be stopped.
V-437-41312
Event ID: 41293 An unexpected error has occurred.|Error Summary: Indexing Service start up error |Error Details: Fatal error in Indexing Service child process EV Indexing Engine Elasticsearch. Further error information: | Error while waiting to achieve the requested state Running. |Reference: ServiceBaseEx::Run |Stack Trace: at KVS.EnterpriseVault.ProcessManagement.ChildProcessManager.StartChildProcesses()| at Symantec.EnterpriseVault.Indexing.Admin.StateManager.StartChildProcesses()| at Symantec.EnterpriseVault.Indexing.Admin.IndexAdminService.OnPerformStartup(Boolean HotRestart)| at KVS.EnterpriseVault.Common.ServiceBaseEx.Run()
V-437-41293
A Dtrace of the EVIndexingEngineElasticsearch process will show the following:
(EVIndexingEngineElasticsearch) <evsrv00:16552> EV-H {ElasticsearchLogger} Error: Could not find or load main class Vault\Temp\elasticsearch
(EVIndexingEngineElasticsearch) <evsrv00:16552> EV-H {ElasticsearchLogger} Caused by: java.lang.ClassNotFoundException: Vault\Temp\elasticsearch
Cause
This issue is caused when the TEMP/TMP folder location for the VSA has a space in the path. For example: D:\Enterprise Vault\Temp
This will cause the Elasticsearch engine to be unable to complete its startup routines.
Solution
Update the VSA TEMP/TMP folder location under Environment Variables to be a path without spaces. For example: D:\Temp