システム状態またはシャドウコピーコンポーネントのバックアップが VSS スナップショットエラーで失敗します

Article: 100058569
Last Published: 2023-07-03
Ratings: 0 0
Product(s): Backup Exec

問題

システム状態またはシャドウコピーコンポーネントのバックアップが VSS スナップショットエラーで失敗します。

 

エラーメッセージ

V-79-10000-11226 - VSS スナップショットエラー。選択した Microsoft VSS(ボリュームシャドウコピーサービス)スナップショットテクノロジによって返されました: "予期しないプロバイダエラー"。すべてのプロバイダサービスが有効で開始できることを確認してください。詳しくは Windows のイベントビューアを確認してください。

アプリケーションイベントログに次のエラーが表示される場合があります。

イベントの種類: エラー
イベント ソース: VSS
イベント カテゴリ: なし
イベント ID: 12292
説明:
ボリューム シャドウ コピー サービス エラー: CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} [0x80080005] (または [0x80070422]) を使用してシャドウ コピー プロバイダー COM クラスを作成中にエラーが発生しました。


イベントの種類: エラー
イベント ソース: VSS
イベント カテゴリ: なし
イベント ID: 11
説明:
ボリューム シャドウ コピー サービス情報: CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} と名前 'プロバイダー名' を持つ COM サーバーを起動できません。 CPU の負荷が高い可能性があります。 [0x80080005] (または [0x80070422])


原因

これは、次の原因で発生する可能性があります。

  • VSS 操作が発生したときに、ボリューム シャドウコピーまたは Microsoft シャドウ コピーコンポーネントサービスが起動しないか、スタートアップの種類が「無効」に設定されています。
  • Microsoft シャドウコピーコンポーネントが DCOM 内に正しく登録されていません。
  • Microsoft シャドウコピーコンポーネントがオペレーティング システムに正しく登録されていません。


解決策

・ボリューム シャドウ コピーと Microsoft シャドウ コピーコンポーネントサービスのスタートアップの種類が手動または自動に設定され、開始できることを確認します。

・コマンドプロンプトで "DCOMCNFG" を実行し DCOM 構成ツールを開き、Microsoft シャドウコピーコンポーネントが [DCOM 構成] の下に一覧表示されていることを確認します。一覧に表示されていない場合は、次のコマンドを実行して必要な dll を登録します。

"regsvr32 /i %windir%\system32\swprv.dll"

・スナップショットエラーが発生しているサーバをジョブログから確認します。次に、同じサーバーでコマンドプロンプトを開き、次のコマンドを使用して VSS ライターのステータスとプロバイダーを確認します。

 vssadmin list writers 

※ すべてのライターは "安定"、"エラーなし" と報告される必要があります

 vssadmin list providers

※ ほかのハードウェアのプロバイダーがない場合、Microsoft Software Shadow Copy provider である必要があります。

・オペレーティングシステムが最新のパッチに更新されていることを確認します。
 

Was this content helpful?