The script " install_client_files " fails after upgrading the NetBackup servers

Article: 100055443
Last Published: 2023-03-20
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

After upgrading the NetBackup server to a newer version of NetBackup 10 and above, the clients may also require upgrading. 

For UNIX/Linux servers the script called ' /usr/openv/netbackup/bin/install_client_files ' can be used to push the client binaries from the server to the clients for an upgrade or installation.   

The problems have been observed wherein some older clients may still show the older operating system kernel which are now, unsupported with the new NetBackup 10.x application.

 

Error Message

Installing NetBackup software on <client-name> as user root

Validating entries in answer file: [/tmp/bp.876062/install_client_files_answers.876062].
INCLUDE_JAVA_GUI_AND_JRE = EXCLUDE

ERROR:   The above invalid entries were found in the answer file. Please remove
         them.

       <client-name> install failed

 

Cause

Older versions of the NetBackup client software which are now unsupported will not be updated or removed during the NetBackup server upgrade.  Therefore, any clients referencing this older operating system version will fail during the upgrade/install process as they are attempting to install non-supported NetBackup client version.

After an upgrade, previous non-supported client versions can still exist.

 

Solution

Check and amend the operating system version defined for the failing clients in the policy details. 

The client hardware and operating system details are displayed when running the command ' /usr/openv/netbackup/bin/admincmd/bpplclients ', these details are set in the policy where the client exists.

After the primary server has been upgraded, if using scripts like ' install_client_files ', the clients with unsupported operating system versions will experience problems.  If the client can support the newer version of the NetBackup software, update the policy details (client operating system) where appropriate.

For example:  The problem above was noted when the client was using ' RedHat2.6.32 '.  Because the directory ' /usr/openv/netbackup/client/Linux/RedHat2.6.32/ ' existed with the older software available, hence the failure occurred. 

To resolve the problem, the client hardware and operating system version in the policy needed to be changed to ' RedHat3.10.0 '.

 

There are currently no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. While this issue may be resolved in a future major revision of the software at a later time, it is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns.

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