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問題
Backup Exec で大規模な SQL データベースのバックアップを行う際に、常にほぼ同じサイズのところでバックアップが失敗します。
次のエラーメッセージが SQL エラーログとシステムアプリケーションイベントログに記録されます。
Operating system error 995
単一または複数の 小規模な SQL データベースのバックアップは 正常にバックアップできます。
エラーメッセージ
SQL エラーログ:
BackupIoRequest::ReportIoError: write failure on backup device 'xxx'. Operating system error 995 (The I/O operation has been aborted because of either a thread exit or an application request.).
アプリケーションイベント ログ:
Date: Date and Time
Log: Application
Event Type: Error
Source: MSSQLSERVER
Computer: Servername
User: Username
Event ID: 18210
Description: BackupVirtualDeviceFile::RequestDurableMedia: Flush failure on backup device 'xxx'. Operating system error 995 (The I/O operation has been aborted because of either a thread exit or an application request.).
Date: Date and Time
Log: Application
Event Type: Error
Source: MSSQLSERVER
Computer: Servername
User: Username
Event ID: 18210
Description: BackupIoRequest::ReportIoError: write failure on backup device 'xxx'. Operating system error 995 (The I/O operation has been aborted because of either a thread exit or an application request.).
原因
この問題は、SQL サーバーが稼働しているオペレーティングシステムの仮想メモリの制限が原因で発生します。
解決策
1) SQL API が SQL データベースを正常にバックアップするために必要なすべてのアクションを実行できるように、オペレーティングシステムの仮想メモリを増設します。
2) VMware の仮想マシンに SQL サーバーがインストールされている場合は、以下の手順を試します。
・VMware tools 及びリモートエージェントをアンインストールます。
・VMware tools をインストールしてから、リモートエージェントをインストールします。
・バックアップをテストします。
注: リモートエージェントベース および AVVI (Agent for VMware and Hyper-V) バックアップの両方が、上記のエラーの影響を受ける可能性があります。エージェントベースのバックアップは、「0xe000ff19 - SQL Server リソースで通信障害が発生しました」というエラーでも失敗する場合があります。