Number of Items Indexed in certain Index Volumes is not accurate

Number of Items Indexed in certain Index Volumes is not accurate

Article: 100054530
Last Published: 2022-12-15
Ratings: 0 0
Product(s): Enterprise Vault

Problem

The count of certain index volumes within an index volume range is not accurate. This can occur even if the index volume reports that no items are missing. 

 

Error Message

A count of the Index Sequence Number range confirms the number of items that should be in the index volume. 

 

Note: The count of Index Volume range 1453130 -  6453197 is reported as 4998306 however the count is 50000068.

 

A dtrace of the Index Verify task while performing a verify against the Index Volume shows the following:

The TotalItemsToProcess in the range is 50000068.

 

<VerifyToolCheckpoint><ReportIntroWritten>true</ReportIntroWritten><TotalItemsToProcess>50000068</TotalItemsToProcess><ItemsProcessed>50000068</ItemsProcessed><MissingItems>0</MissingItems><ExtraItems>0</ExtraItems><ItemsMissingContent>11</ItemsMissingContent><ItemsWithAttachmentsMissingContent>2116</ItemsWithAttachmentsMissingContent><AttachmentsMissingContent>0</AttachmentsMissingContent><LastProcessedSeqNum>6453129</LastProcessedSeqNum><HighestAcknowledgedAdditionSequenceNumber>624931</HighestAcknowledgedAdditionSequenceNumber><HighestAcknowledgedDeletionSequenceNumber>0</HighestAcknowledgedDeletionSequenceNumber><HighestAcknowledgedUpdateSequenceNumber>0</HighestAcknowledgedUpdateSequenceNumber><HighestISNFor32BitVolume d2p1:nil="true" xmlns:d2p1="http://www.w3.org/2001/XMLSchema-instance" /><IndexedItemsCountFromIndex>4998306</IndexedItemsCountFromIndex><SeqNumStatus>Valid...

 

The IndexedItemsCountFromIndex in the range is 4998306. 


A dtrace of the Index Verify generates a report:

4998306 indexed items
0 missing items
11 items missing content
2116 items missing content in attachment(s)
0 extra items that do not exist in the archive

 

Cause

This issue is caused by a flaw in the Index Verification logic

 

Solution

There are no plans to address this issue by way of a patch or hotfix in earlier versions of the software at the present time.  However, the issue has been addressed in the revision of the product specified at the end of this article. 
 
Please contact your Veritas Sales representative or the Veritas Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.

 

This issue has been addressed as part of Enterprie Vault 14.3.1

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