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Post upgrade to VIOM-8.0U2SP1 (8.0.0.210), VIOM users may not be able to login to the VIOM GUI

Article: 100054213
Last Published: 2022-10-20
Ratings: 0 0
Product(s): InfoScale & Storage Foundation

Problem

Post upgrade to VIOM-8.0U2SP1 (8.0.0.210), VIOM users may not be able to login to the VIOM GUI

 

Error Message

When logging into the VIOM GUI, the error below will be reported:

Failed to login, Username or Password or Domain is incorrect

 

Cause

The cause relates to the /var/opt/VRTSsfmcs/conf/esmweb.cfg having 2 merged lines after the upgrade.

 

Solution

To fix the login issue, please follow below steps on the VIOM Management Server:

 

1) Take a backup of the /var/opt/VRTSsfmcs/conf/esmweb.cfg and edit it

 

2) Search for the JAVA_OPTS line

 

3) If the JAVA_OPTS line is merged with some other line, separate into 2 unique lines. In the below example, JAVA_OPTS line is merged with EATHOMEDIR.

JAVA_OPTS='-Xms1024m -Xmx2048m -XX:MaxPermSize=1024m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/var/opt/VRTSsfmcs/logs/webserverdump.log'EATHOMEDIR=/opt/VRTSsfmcs/sec

 

Separate the merged lines into new lines (and save the file), e.g.

JAVA_OPTS='-Xms1024m -Xmx2048m -XX:MaxPermSize=1024m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/var/opt/VRTSsfmcs/logs/webserverdump.log'

EATHOMEDIR=/opt/VRTSsfmcs/sec

 

4) Restart VIOM web service:

# /opt/VRTSsfmcs/bin/vomsc --restart web

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