Problem
Oracle Intelligent Policy backup fails with exit status - 5455 The Oracle backup did not start
Error Message
Detailed status in activity monitor shows error:
ERR - bphdb exit status = 5455: The Oracle backup did not start
Info bphdb done. status: 5455: The Oracle backup did not start
end writing
bpdbsbora log on the Oracle client shows error:
OracleDllManager::open: Using library at [/u01/app/oracle/product/19.0.0/dbhome_1/lib/libclntsh.so] (../OracleDllManager.cpp:104)
OracleDllManager::open: Failed to open library [/u01/app/oracle/product/19.0.0/dbhome_1/lib/libclntsh.so] (../OracleDllManager.cpp:151)
OracleDllManager::open: Error was:libnnz19.so: cannot open shared object file: No such file or directory (../OracleDllManager.cpp:152)
OracleOci::init: failed to load oci library [4] (../OracleOci.cpp:116)
Cause
1) Although these libraries like libclntsh.so and libnnz19.so are present at the Oracle home path, but when backup runs via Oracle Intelligent Policy, it looks for these libraries at /usr/openv/lib
2) Check the user which customer trying has got sufficient permission to access the libraries or isolate it.
Solution
1) Implement the following work around in case you root cause is missing libraries.
- Check the bpdbsbora logs and make a note of the libraries that the backup job is failing on.
- Copy these libraries from the Oracle home path to /usr/openv/lib
- Also create a soft link for library libclntsh.so as shown in example below, and then the backup will work.
Example:
After analyzing the bpdbsbora log, below libraries must be copied from the Oracle home path to /usr/openv/lib and a soft link created to allow the backup job to be successful.
-rwxrwxrwx 1 root root 6587832 Aug 31 16:38 libnnz19.so
-rwxrwxrwx 1 root root 8040712 Aug 31 16:42 libclntshcore.so.19.1
-rwxrwxrwx 1 root root 79942576 Aug 31 16:42 libclntsh.so.19.1
lrwxrwxrwx 1 root root 17 Aug 31 16:44 libclntsh.so -> libclntsh.so.19.1
2) Try following if the issue is with the user permission.
- Please try the SYS or SYSTEM user from oracle to register the OIP from master. As these are power user,
we should able to register the instance. which indicates the issue with user customer facing issue with. Adding the
right permission on the preferred user should fix the issue.
3) Check whether RMAN catalog check box is checked and the credentials for the same are correct, This can occur due to communication issues with the RMAN Catalog Server in the oracle application, The dba have to look into it.